Return to Level1Techs.com

Ubuntu Host, Windows VM, EFI

So I have A ubuntu host machine with a Windows VM, the windows VM has its own GPU, USB-3 interface and a M.2. Now whenever I boot up, I have to PRess F-11 and select the Linux M.2 to boot into Ubuntu.

Anyone have a link on how to fix this? Specifically have the EFI ignore with windows Boot manager when the Host OS is starting up?

It’s a Taichi x399.

Thanks

Try checking the boot priority of drives in the UEFI?

Sorry didn’t see the response… Yes the priority is the my Ubuntu M.2 SSD. The EFI still continues to try and RUN the windows Boot loader. Hopefully there is an easy command in Ubuntu that will fix the issue.

Thanks again for the info. PS please if I haven’t given enough info, let me know what other info might help!

I have a similar issue with X370 taichi motherboard. Using the F11 prompt for boot selection does not permanetly change the boot device. Once the windows drive was selected via the F11 prompt the only way for me to permanently change it back to the Ubuntu boot drive is to manually go into the UEFI BIOS and change the drive from the device boot order screen.

I don’t believe the F11 prompt is a “quick boot menu” so maybe it’s a particular quirk with Asrock or the Taichi series boards…:man_shrugging:

Hmm, are you using Grub on Ubuntu? Not systemd boot or anything?

Also, is Ubuntu booting in EFI or BIOS mode?

For me, F11 works… The boot loader wants to boot to Windows. I am using Grub on Ubuntu. Ubuntu is EFI, as is Windows.

Thanks TheCakeIsNaOJ

So if I am understanding this correctly it is trying to boot the Windows boot loader even though there is a theoretically higher priority EFI Grub entry selected in the UEFI settings. But then it does boot to the Grub entry if selected via F11.

That sounds like a UEFI problem to me, which is one of the cases where a UEFI update should be tried. If that does not work, try contacting AsRock support.