Ubuntu GNOME doesn't boot from USB


I've been encountering a problem while attempting to boot into Ubuntu GNOME via a bootable USB. The motherboard I am using is a ASUS Z97 Deluxe, and I have configured the secure boot setting in the BIOS to "Other OS".

This is the error I am receiving:

More details:
- I've tried using UNetbootin and Rufus
- I am booting from the USB in UEFI mode

Some PC specifications:
Motherboard: ASUS Z97 Deluxe
CPU: Intel Core i7-4790K LGA1150
SSD: Samsung 840EVO x1

Change your bios to boot from UEFI mode ,most recent distro accept UEFI mode now.

How exactly do I do that? I'm booting into the USB via UEFI mode.

Try going in and disabling secureboot and enable legacyboot, and then go through the boot menu and it should start up.

Changing something shouldn't be required at this point. As you can see in Screenshot, the Kernel is already loaded, and now trys to access a drive. If I'd had to take a guess, you're trying to repair a drive? Last time I saw this error, I was. Turned out to not even be the boot drive, but a cable failure in another(The drive in question, an old Samsung 2.5" HDD runs great to date, only the cable gave up on me :O). Try removing your main SSD temporarily from the System. Also, it might be that the USB-Stick you're using is faulty/doesn't quite comply with SCSI standarts. Try anotherone if you can!
If you've plugged in your Stick in a Front-Panel connector, try the Backpanel, as USB-extensions sometimes create problems. Also, make sure that the USB-Stick you're using doesn't takes to much power. If you plugged in a USB3 port, plug it in a 2.0 port, and vice versa(USB3 delivers more power, but might have driver issues)
If all that doesn't help, try changing up the BIOS/UEFI settings for USB(For example, the USB Legacy mode, or Quickcharge-Things).
Also, have you tried to just wait a few minutes? AFAIK, if Linux can't mount a drive in 1,5min, it just skips it. Maybe it's the same with ATA-Devices :D

Thanks all for the help attempt, I've decided to just stick with Windows for the time being as it's designed to be used by my MB.