Ubuntu Gnome 14.10...cannot even select menu tabs in programs

I just installed Ubuntu Gnome 14.10 and this has been quite the adventure, I've reinstalled many times due to unrecoverable frustrations but so far it's been rather...stable. I'm trying to get oracle virtualbox running but cannot select the Windows image let alone get into the menu tabs, I don't know what's wrong. I haven't really changed the gnome settings much, all I did was change the theme to dark and that's it.

Firstly if you are having stability problems you should try 14.04 LTS not 14.10.

Try changing the theme back to the default. It may be that the text colour is the same as the theme.

Is pitcairn supported in 14.04? And what features will I miss out on if I revert to 14.04?

Cause I was led by wendell's video on installing linux and just used the 14.10 gnome image. It's not that I cannot install linux it's just the problem for me was what to do after it's installed.

Well it sounds like virtual box is missing some dependencies.

Did you update your system after installing it?

Also, what are you trying to install on windows? Chances are that PlayOnLinux would be a better solution.

MS Office, that's it, my work requires it and they won't let me use libreoffice. I've updated including dist-upgrade before I did anything

You can run Office 2003, 2007 or 2010 using 'Play on Linux' (install through Software Centre)

I use 2013

I installed virtualbox through the software centre, do you want screenshot of the problem?

Any possibility that you could downgrade 2010? It is very similar to 2013 and you will have a native-like experience if you run it through Play on Linux.

A screenshot would help.

Have you tried doing it with the default theme?

I don't have any previous versions and yeah, tried with default theme

The disc icon is selected but the drop down does not appear

And why does the X.org driver always change back from my ati proprietary drivers? This is pretty annoying.

Where are you changing your gpu driver at?

I am running 14.10 VBox and the drop down menu appears for me...? You would have to have had changed something.

It's a fresh install, tut from wendell's videos. I changed the driver in the software & updates program. I have a pitcairn ATI radeon 7870HD GHz edition. Should I just go to 14.04 to fix all this?

Are you installing Windows 8.1 from a DVD or ISO?

If it's a DVD, just check the the Live CD/DVD

If it's an ISO, click on the dropdown on the far right of where is says, "CD/DVD Drive:"

Installing it via ISO image, but I cannot use that drop down since it won't let me...