Ubuntu doesn't boot after Nvidia 418 install

So I had to reinstall Ubuntu and the last version I had was 18.10. In 18.10 from what I can tell it’s required that you disable Wayland before rebooting because the Nvidia driver isn’t compatible with Wayland. From what I’ve been able to gather 19.04 has Wayland disabled by default but when I install the driver I can’t get to the login screen. I get stuck at “Switcheroo Control Proxy service”. I’m not sure what the issue is our how to fix it.

1 Like

Is there a reason you want/need 19.04? 18.10 is supported and getting updates. Problems like these are why I went with mint or a LTS version.

1 Like

Mostly because it has a newer version of gnome that fixes some of my complaints that I had with the old version. I know you can update gnome without installing a different version of Ubuntu but I haven’t gotten that to work. Everytime I try I end up with a no boot install and need to either reinstall it spend hours typing in commands until it works again.

I’m not sure what your problems with gnome are but I’m going to recommend fedora to you. Its far more up to date on pretty much everything and has similar software support to ubuntu with rpmfusion. The negativo17 repo should be used to install video drivers.

It goes something like this, install fedora, do all your updates, add rpmfusion and negativo17 repo, install nvidia drivers from negativo17, enjoy your up to date linux experience.

I know its not a solution to your problem and I definitely dont want to advocate for distrohopping but in this case I think it makes sense.

what do you think @AnotherDev?

1 Like


I am not aware of this.

Revert the settings you made and see if it boots.

Fedora is a good option, but Ubuntu should work with latest Nvidia.

1 Like

Hes brand new to teh gahnoo ploos leenux

1 Like

I’ve wanted to try another distro as I’ve had alot of issues with Ubuntu over the years but it’s the only one I know and I’m still very much a noobie when it comes to Linux. I will look into Fedora for sure as I’ve heard good things about it.

could this help?

you’ll have to chroot into it from liveusb I guess

Everytime I install the official drivers I have to jump through 50 hoops to get it to work. I will have to do things like disable Wayland, blacklist nouveau and edit boot stuff and maybe if in lucky it will boot. From what I hear the situation is much better for AMD GPU users.

Its really not as bad as you might think to switch. I had apprehension to moving to something else because I didnt want to learn a new package management system but with fedora you can literally just replace apt with dnf in most cases and get the same result.


These instructions have always worked for me.

I’ve used all three methods. Nothing involves disabling Wayland or anything like that.

I’ve already read that post but it isn’t in-depth enough for me. Also I can’t figure out how to save grub edits so it boots with the charges. It’s supposed to be F10 to boot with temporary changes but it doesn’t seem to work for me.

That’s Linux, man. Not trying to be discouraging, but generally your first few times are going to be rough.


I followed that guide and it got me here. I installed the PPA version because that’s what I used on 18.10 and it allowed me to easily change between driver versions of I had any issues.

1 Like

Am also a beginner. Can confirm that Fedora is a delight to work with, despite people saying it’s bleeding edge and unstable. Try it. You’ve nothing to lose…well, be careful, but yeah.


Yea I just wish they’d fix some of the major issues. For example installing Nvidia drivers requires setup outside of just installing the actual driver and for some reason nobody has thought to fix that by making the extra steps automatic. Idk maybe it can’t be but it’s pretty bs for us mainstream Linux users who wanna jump ship from Windows.

1 Like

What GPU? I can give it a whirl on 19.04, see if I can find a quick/obvious fix. Don’t expect miracles with me, though :sweat_smile:

If you want newest drivers to work out of the box, try Manjaro Linux. That is if you want to jump ship from Ubuntu.

I’ll give it a shot. I remember trying it years ago and it looked like ass and didn’t work properly for me at the time. Maybe it’s different now. I’ll give it a go.

1 Like

once you edit /etc/default/grub you just do sudo update-grub