Return to Level1Techs.com

Ubuntu: But I don't have the damn CD/DVD

Installed Ubuntu 18.04.
Tried to install additional software …

  1. VirtualBox
  2. Gimp
  3. Kdenlive

… all listed in the “Software Boutique”.

And it says …

"Please insert the disk labeled … "

Computer DOESN’T have a damn optical drive!

Tried the CLI …

"Please insert the disk labeled … "

Computer DOESN’T have a damn optical drive!

WTF!!!

Now what?

And people recommend Ubuntu for beginners?

First off, you’re talking about Ubuntu MATE, not vanilla Ubuntu. (Best that I can tell because Software Boutique is unique to them)

Second, its because you still have the installation media set as the default repo.

You need to disable that and then it will fetch the needed updates from online.

Please read this page to see how to enable/disable that: https://help.ubuntu.com/community/Repositories/Ubuntu

3 Likes

" … You need to disable that and then it will fetch the needed updates from online. … "

I understood that, and I tried to, but it was grayed out ( non-selectable ).
Several times in fact. That’s part of where the frustration came from. Even tried marking/un-marking the other repos in the GUI just to see. To no avail.

In fact the url you suggested was what I was looking at while I was trying to figure this out.

And yes I know that Ubuntu Mate is not “vanilla Ubuntu”, but none of the other DEs fit my “workflow” ( I’m old and Gnome, Gnome 2 were my goto DEs ) so Mate is what works for me.

And Thank You for your reply!!!

How odd! I’ve used each version of Ubuntu-Martin since about 15.10, but only ever used the USB.

Do any other distro’s do that when installed by CD?

“if you have no internet connection you can still install software from the CDs.” I’d imagine it also refers to USB or whatever method of accessing the installation ISO. Are you using wifi? Is there any connection issue? Is there a way to plug in an ethernet cable (if not already being used)?

The fact that the distro and the documentation both refer to the ISO as a “CD” is antiquated and slightly misleading by this point in time.

You could try the .deb file from the Debian archives, but then it could have an issue pulling the dependencies unless you mount the USB drive to pull from.

Just dawned on me, but have you run “sudo apt update” and “sudo apt upgrade” before trying to install any packages? I mostly use synaptic or muon for installing software, but regularly update via the command line with “sudo apt update && sudo apt upgrade”. Without updating the repositories it might not be trying to pull from them (huge guess, never seen this problem). Either way, you want your packages up to date before installing anything new.

You’re welcome.

And the reason for the specifics is there are small differences between all the *buntus so it’s imperative to be precise.

We’ll likely have to just see what is in your apt sources list. If you usb/DVD/iso is there at the top we just need to remove or comment it all out.

^This

What is in your /etc/apt/sources.list and /etc/apt/sources.d/* files?

The real question is how did that happen in the first place? Is the ISO bad? I’ve learned my lesson about checking ISO files before using them.

Not usually, but if you don’t pay attention during the installation then just select ‘yes’ it will do this.

At the end there’s usually a blurb about, “would you like to use this USB as a primary install source… blah blah blah”. Something in that vein. If you select yes, then you will have this issue out of the gate.

If he plugs his install usb back in and then tries to install his packages I bet you it will work. Because it has to be connected to pass the check.

So back to my point, why not just manually updated the sources.list files to comment out the Media and if so, manually add the repositories?!

get a usb cd/dvd reader/writer off amazon or wherever you prefer. easiest option and things like this will come up again.

got something like this when I took debian for a spin, turns out I had to remove some mirrors on the apt list, there were 3 or 4 pointing to the damn cd/dvd, must be this:

As a Debian GNU/Linux guys, it is usually always this.

By the way, I use Arch. /s

**Edit
I hope that is the last time I have the urge to use that meme. But I do use Arch. Debian is just my main environment.

Someday I’ll go through all the hassle just for the bragging rights.

Then I’ll go to Gentoo for the same reason.

But that day is pretty far away cause right now time is a precious commodity which I don’t have.

1 Like