Ubuntu asking for permissions when trying to connect to a Teamviewer session

At my workplace, we got an Intel NUC that just shows our server monitoring. This is just a website that we open in full screen on it. The NUC is connected to a TV and stored away. Occasionally, we need to connect to it somehow to make updates or do other changes. We use Teamviewer for everything at our workspace, so I must use it for this too ( not my decision). Now I have the problem that every time I try to connect to it, Linux asks me to give remote desktop permissions. This is not really useful as there is no means for input on the device.

Is there some way to make Linux give permissions always?

I tried the settings within the sharing subfolder, activating everything, sadly this did not change anything.

So I did switch it to linux today.