Return to Level1Techs.com

Ubuntu 20.04 Virtual Box install freezes at "copying files"

Sorry in advance if this post is in the wrong place.

I recently updated to Virtual Box V6.1.12-139181 and I’m trying to create a fresh Ubuntu VM with Ubuntu 20.04 LTS. I can get through all the prompts but when I get to the final screen that shows the install progress it hangs, and says “Copying Files”. I’ve tried this many times, with different Virtual Box versions, different Ubuntu Versions but all yielded the same result. Has anyone had issues similar to this or have any ideas to why this is happening?

PC:
AMD Ryzen 9 3900x
Asus Tuf Gaming x470 Motherboard
Trident Z Neo 32GB 3600Mhz RAM

Virtualization is turned on in the bios.
I have AMD’s “XMP” enabled in the bios.
Hyper-V is enabled as well as Virtual Machine Platform & Windows Hypervisor Platform in Windows Features.
These are enabled for WSL2 & I was testing Windows Hyper-V

(I have Windows 10 Professional)

I gave the VM 14GB of RAM, 8 CPU Cores, and 60GB of HDD space (It is being installed on a SSD).

If you need more information please let me know and I will try to get you what I can.