Return to Level1Techs.com

Ubuntu 19.04 steam issues

helpdesk
#1

Hello everyone, I have a very amateur question to ask. So, I just updated my laptop from pop os 18.10 to ubuntu 19.04. All was well with my last setup. Everything worked just perfectly fine. But that new ubuntu update was just calling my name. And I loved the side bar that ubuntu had. So I updated it.

The downside is now I can’t play any of my window’s only steam games. Proton 4.2-3 worked perfectly fine before the update. But now after updating to 19.04, none of my window’s games works. I installed everything I could think of. Wine 4.0 stable branch. Lutris, and I even reinstalled everything on a clean unit.

And nothing helped. My laptop is Acer nitro 5 with a nvidia gtx 1050ti with a i5 7th gen.

Any bit of help will be greatly appreciated.

1 Like

#2

Do you get some errors?

0 Likes

#3

Not that it will help at this point, but with new generational releases from distros like Ubuntu, it’s not a great idea to upgrade from your previous gen installation. Clean install is always the best option.

That being said, as Yoray asked; can you share any or all error messages you might be seeing?

If you were using a system backup application like Timeshift, you’d be able to roll back to the previous working state of your system.

0 Likes

#4

I’d recommend staying on LTS if you don’t want breakages of these things

1 Like

#5

Update your GPU drivers to the new ones in release?

0 Likes

#6

This is a Nvidia Optimus/Prime issue. The hybrid graphics solution only allows OpenGL graphics to run on the Nvidia GPU, not Vulkan.

This issue is for Manjaro, but it’s the same idea:

1 Like

#7

I believe there is work being done to fix this

0 Likes

#8

How well did the games work on Pop?

0 Likes

#9

I have an ubuntu box that’s been upgraded since Dapper, 13 years ago. I occasionally get errors on a major upgrade but so far they’ve all been recoverable. No doubt that a clean install is the best option, but it totally isn’t required.

That said, he upgraded from an Ubuntu respin “pop OS” to Ubuntu, and that is a bit trickier for sure.

1 Like

#10

Did you installed your graphics drivers from the graphics-drivers ppa? if so, did you checked you’re using nvidia-prime instead of bumblebee? as FurryJackman said, bumblebee doesn’t support anything but opengl, so dxvk, proton and all that fun stuff doesn’t work with bumblebee unless you have nvidia-prime that does support vulkan on optimus laptops

0 Likes