Ubuntu 17.10 upgrade problem

Since upgrading to Ubuntu 17.10 I have this weird problem that netowrking doesn’t work all the time. Sometimes the notebook just won’t connect to my WiFi, other times it connects without any problems.
I had no issue whatsoever before the upgrade and I did neither change my routers location, nor the notebooks location. Any ideas?

Looks like you are not alone: https://askubuntu.com/questions/967637/wifi-not-working-in-ubuntu-17-10-version

I upgraded a family members lappy to 17.10 and everything worked fine. Not being snarky, just comparing notes for ya.

Also, it might help to list your actual wifi “card” or chip.

Thanks for the info :slight_smile:

My wifi card:

*-network
description: Wireless interface
product: AR9462 Wireless Network Adapter
vendor: Qualcomm Atheros
physical id: 0
bus info: [email protected]:03:00.0
logical name: wlp3s0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=4.13.0-16-generic firmware=N/A ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:16 memory:fea00000-fea7ffff memory:fea80000-fea8ffff

AFK for the day. Will try and help when I get back to the cave.

1 Like

https://certification.ubuntu.com/catalog/component/pci/1028%3A0300/168c%3A0034/

Listed there. Odd that you are having issues.

1 Like

Maybe try the most voted solution here (82 by my count at this time): https://askubuntu.com/questions/902992/ubuntu-gnome-17-04-wi-fi-not-working-mac-address-keeps-changing

2 Likes

Thanks for the info, I’ll update my progress here :wink:

I seem to already have this line. I just realised though that it works fine if it is set to DHCP. However, I would tremendously prefer to be able to use a static IP, as I’ve done before. (I’ve set it to a static IP through its GUI).

To get a static external IP you have to contact your ISP. Internal you have the power to do whatever you want. I don’t think most IPS’s would do this.

Please correct me if I am wrong or misunderstanding.

In ‘sudo nano /etc/network/interfaces’ you would static your IP.

1 Like

I would not edit the interfaces file for a desktop system; this will prevent the GUI from managing the interfaces. Just use the GUI.

2 Likes

Seems you can run into this issue witth the killer NICs Too.

I just downgraded back to 17.04

1 Like

Can’t wait for 18.04! Might move back to 'Buntu as my primary driver for a bit just to test it out!!

That will be interesting.

I was actually talking about an internal static IP at home. I prefer this because I use this notebook to watch Netflix and I have a SSH remote on my phone and I also use VNC to connect to this machine for other reasons. As a result, I don’t really want to figure out the IP of this machine every time I connect. Hence, static internal IP.

I tried editing the interfaces file, but it resulted in no connection at all. The weird thing is that my static IP works about 1/3 of the time.

Highly unlikely with so few devices, but are you getting an IP conflict where two devices try and say they have the same IP?

I haven’t actually checked it but I doubt it, since most devices in my network have a static (internal) IP in the first place and besides, I have placed their number rather high and my modem tends to lend IP addresses from the bottom up. E.g. x.x.x.2 is leased before x.x.x.3 is and so on…

for it’s worth i’ve been finding a number of oddities with 17.10

Thanks for the info, I changed the settings accordingly, but I strongly believe that my problem is related to 17.10 and not my router since everything worked fine earlier.

The problem continues. Ubuntu ignores the static IP set through the GUI and gets a random one through DHCP. This is so strange…

If your router allows it, you can use static leases instead of setting static IPs.

I know DD-WRT has this feature. This way you can still have the PC set to DHCP and get the same IP every time.

This is how I set my systems up at home.

1 Like