Ubuntu 14.10 resolution problem

I recently installed Ubuntu with Gnome on a partition of my Windows drive. At first it would not recognise my 1920x1080 HDtv (which I use as my primary monitor) and displayed everything on my secondary monitor (1280x1024). When I installed the Nvidia drivers and re booted my system it recognised the HDtv however it was locked at 4:3 with the only two resolution options being 800x600 or 640x480(scaled). I tried changing it in the display settings and the Nvidia control panel but it wouldn't let me even if I tried to change the resolution manually. I also tried booting up with only the HDtv connected but it was still stuck at 4:3. Is there a fix for this?

I am running a FX-8350 in a Gigabyte GA-970A-DS3P motherboard with 8Gb of DDR3 and a GTX 970

Nvidia drivers and Linux don't always get along the best. Linus Torvalds once famously said "Fuck Nvidia". So theres that. I would backtrack through the problem; reinstall drivers, roll them back to previous version, etc. Try another monitor too, it may just not be detecting the tv correctly

Thanks for the advice ill get to it when I've got the time and report back if I still have any problems.


Replace '346' with '349' for the beta drivers.

you can also try setting your screen resolution with xrandr. Type xrandr in the terminal to check if there is any resolution there which was not listed in the display menu/nvidia control panel. Then you can change with resolution like this:

xrandr --output HDMI-0 mode 1920x1080

(Assuming the your hdtv is named as HDMI-0 and there is a 1920x1080 listed)

It might won't list any new, but give it a try before reinstalling all your drivers.

The beta driver allowed me to select a 16:9 resolution but the highest is only 1360x768. I can manually change the ViewPortIn to 1080p but not the ViewPortOut so im still stuck at a low res.
Also in the screen display settings it is listed as a 4:3 monitor.