Ubuntu 12.04 Broadcom 43xx recent update

As some may know, I usually have to type in the terminal “sudo modprobe b43″ in order to get the wireless driver running on my Compaq v5000. One issue I just ran across today was apparently after I installed the recent Ubuntu updates, that method seemed to fail to enable my wireless. After the updates, I would type in the command shown above, and the terminal would simply hang as if it was trying to enable my device.

What I did not know, was, Ubuntu ships with supposedly a “proprietary” driver listed as “wl,” and it appears there was a recent update for this which makes using modprobe to switch to b43 hang everything. The solution was quite simple, yet annoying, uninstall “wl.”

“sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source”

After this, I restarted the computer and I immediately noticed that I no longer had to enter “sudo modprobe b43,” but apparently Ubuntu’s wireless manager was no longer telling me all of the available wireless connections. I assume that you can use the terminal to connect to a network, so I tried, but before I figured it out after typing in “iwlist wlan0 scan” multiple times and trying to connect to my network, “sudo iwconfig wlan0 essid testShare key s:wasd1,” Ubuntu’s wireless manager began showing me available connections all on its own.

I assume everything is fine for now, but if anyone is following, or landed on this page through google, I will list some of my new findings, and DEFINITELY if anyone has anything to add to this, MAKE A COMMENT! I COMMAND U!



NOTE: The above method only fixes the issue if you already have “b43-fwcutter,” and “firmware-b43-installer” installed. If you uninstall “wl,” you must install all previously mentioned in order to get your wireless working again (if it ever did work to begin with). Run “sudo apt-get update,” then “sudo apt-get install b43-fwcutter,” and then, “sudo apt-get install firmware-b43-installer.”

It appears that when I boot the computer, it automatically connects to the previous network you were on, but it takes about 120 seconds before it will show you a list of availible networks to you. This is a slight annoyance, better than having to use the terminal to enable the wireless though, I think I will leave this be for now and enjoy the peace while everything is working properly.

[Pasted directly from my new blog: https://thephysicalrealm.wordpress.com/ ]