Ubiquiti ER-X Weird network Issues

BLUF: I can pull up websites but no downloads, or apt upgrades, etc. Speed tests show 170 Mbps but I have still have that problem and I believe it is caused by my ER-X.

Background: I live alone in a dorm with cable modem based internet provided by COX in south eastern USA I have a bed, desk and a 42u server rack living the dream I recently left town and shut down all of my equipment for the weekend to conserve electricity. When I came back I was having issues watching youtube running updates downloading files and a slow connection in general I had 0 configuration changes between having no problems and these problems occurring. I replaced the modem had ISP check lines disabled firewall and directly connected to the modem the network would work kind of slow but 80Mbps but as soon as i put the Ubiquiti ER-X in the problems would continue I have a very basic configuration I disabled my firewall and still no luck I have no QOS or anything like that configured.


Attached is a screenshot of an example of the problems.

If you need anything else to help just ask I would appreciate anything.

P.S. I can ping any adrress

Is DNS working?

yes my DNS vm and my external DNS can both resolve hosts

This is a screen shot from the firewall

Sounds like tcp clamping gone wrong, or mtu blackholing.

Try to port forward a download over your er-x.

ssh [email protected] -L 12345:deb.debian.org:80

and try browsing around localhost:12345 and downloading something

Also, try to clamp tcp mss to e.g. 1200 bytes (using the firewall or a sysctl on your host) and see if that helps

Thanks for the help I woke up this morning and everything just worked and the updated the firmware on the ER-X just to be safe. I’m going to do research on TCP Clamping and MTU black-holing just to expand my knowledge and make sure everything is configured properly as I’m not 100% on what those are.

V/R
Spiderspoon

1 Like

Tldr for mss is typically 1460 for ipv4 and 1440 for IPv6. If it’s mixed, use 1440.