Tyan S8030 dimm slot

I’m using a Tyan S8030 with an Epyc 7402. One of my DIMM slots isn’t working properly. It’s definitely the slot and not one of my memory modules (I tested each one in the other slots). Does anyone know of any troubleshooting I can do before resorting to RMA? I know which dimm slot isn’t working properly and I’ve tried removing the CPU from the socket and reinstalling. This doesn’t seem to resolve it either.

Have you tried it with another CPU, as one of the CPU’s memory channel could be broken.
Surprised to see a fellow Vietnamese on this forum, anyway

I don’t have another Epyc CPU to try

Try contact Tyan and see if you can get them to loan you another CPU for testing. If not, try RMA the board

I’ll try this out. Not sure if they’ll loan me one though.

Reseat the CPU could have bad contact on pins

I’ve tried reseating the CPU once. I guess I could check the CPU to see if every pin actually made contact

Hmm, still nothing. I’m tempted to just buy a cheap second hand Zen 1 Epyc to check if it’s the motherboard or CPU. AMD and Tyan support not being very helpful.

The S8030 is only compatible with epyc Rome (and epyc Milan supposedly with a firmware update).

First gen epyc flat out won’t ever work, the firmware for it isn’t present.

2 Likes

are you sure your case doesn’t have a standoff where it doesn’t belong? There is one right under the memory modules that you have to unscrew.

barring that reseat the cpu for sure and make sure theres no debris in the socket.

1 Like

Oh I wasn’t even thinking of this. Thanks for pointing it out. Pretty glad I post to the forums before doing things like this lol

It looks like you might be right. I can’t shutdown right now to remove the motherboard, but it looks like there is a standoff there that could cause the issue. Hopefully removing that will fix the issue. The location looks consistent with the memory channel that is failing.

I’ve reseated the CPU recently, so I don’t think that’s the issue.

I’ve seen reseating more than once be the issue. when you shut the thing wiggle it a bit. Go in the 1-2-3 tighten order but try to halfway tighten 1 2 3 then fully tighten 1 2 3

Wait till after you fix the standoff. hopefully nothing is permanently destroyed now if you missed a standoff.

2 Likes

Had this issue happen with tower macs. Over the course of the year it would “lose” its memory modules. I’d simply powerdown the units, slide out the cpu tray, inspects the ram slots, remove dust off and visible debris, take isopropyl 99% with a swab, cleanse the modules and slots. Wait 'til dry, insert modules and tray back firmly. Cross fingers for the apple chime and back in business. Done this 4 times in the past 3 years.

(Have you also cleared the CMOS and set unit to default)? The memory slot shorting in the chassis wholly possible.

1 Like

Well this fixed it. Thanks Wendell!

2 Likes

Oh there was a motherboard standoff in my case right under the dimm slots. Removing that standoff from the case fixed the issue for me.

@wendell calling out me out again

Hehehe :slight_smile:

There are no less than a half dozen threads here with that issue

2 Likes

Haha but I’m especially noticing the standoff comment on all your case reviews since you pointed it out to me on the forum