Two dead PSUs, two dead motherboards or am I missing something?

Hi Level1Techs community,

I once again come to solicit your wisdom… Friday evening I turned off my work computer and Saturday morning I refused to make a sound. No LEDs, no fans - nothing. Since it was entirely quiet, I expected the PSU to be at fault and ordered a new one, but it yielded the exact same response, so I shifted my opinion to the motherboard to be the culprit. I got another one today, but I still get NOTHING.

The Hardware in Question is:
Initial Build:
AMD Threadripper 1920X,
32GB Crucial DDR4 Ram (2666 Mhz)
Nvidia Geforce RTX 2070
Fractal Ion+ 860W 80+ Platinium

I now also have:
Asus Prime X399-A
Seasonic Prime TX-1000

In terms of trouble shooting I tried:
Disconnecting everything, but it stayed quiet. I took out the GPU to see if it would give me an error code on the LED Display, and it stayed quiet. I got the new Seasonic PSU and tried with that and nothing. I took out the Ram and it stayed quiet. I tried to see if it says anything without the CPU or anything else, just 12 pin power, and for good measure with and without CPU Power and - you guessed it - it stayed quiet.

So I got the Asus board from a local shop today. I mounted the CPU strictly after protocol, seated the RAM, mounted the GPU, connected a Display and a Keyboard, aaaand - nothing. I am kind of out of my depth now, I did the same steps as above and the only thing I didn’t dare yet is the old PSU on the new motherboard.

The Seasonic PSU included instructions to test for basic functionality with the included 12 Pin Bridge and and using the the PSU Fan spins up, so I would guess it should be ok.

Are there any trouble shooting steps I could try? Or did I miss anything? Or could I really have received just a dead board in the store today?

You try a different power source? Maybe the breaker is tripped?

Yes, I tried that as the very first thing. But on the same Surge protector I also have my MacBook charging anyways, so I’d have been surprised. I also tried different power cables and the fan of the PSU spins with the included Seasonic 12 Pin jumper as they outlined in the manual for testing.

Bad power switch? you try shorting the board pins to start

I used the onboard power switch on both the Gigabyte and the Asus board. Do you think there’s a chance both are broken? I didn’t put it in the case yet since I got the Asus board.

Probably not but something you can test.

Quick question.

Did you also replace the psu power cabling inside the pc?
Might be that the 24 pin power or the 8 pin cpu power cable being faulty.

Could be if he didnt swap cables along with psu, guess he could have used same modular cables but dont think he did.

True story… should I reassemble or just test the bare board to see if it gives me a CPU not found code?

Good thought, but yes, I used the included cables of both PSUs. Also not sure if they are the same PIN out motherboard side, so I did it just to be sure anyways.


up to you, should do something even with no cpu

Still nothing… so either I have two dead PSUs or two dead boards, am I right?

PSU self tests good on loop (could be putting out wrong power but unlikely) Double check if modular that cables are firmly seated had issues with that before. (could check older board too if you have it and both PSUs)

1 Like

False alarm… I am a stupid man… I just tried one more time and noticed that for some reason pushing the power input really really hard into the PSU and voila… how could I miss that?

As always, layer 8 Error…

I also just for fun retested the GIgabtyte board and that is still dead… so… I guess I got it… will ensemble now and I hope now it should work

1 Like

take the motherboard with cpu out of the case and put it on a cardboard box.
Install the cooler connect a fan to one of the fan headers on the board.
And try to power it up, at least the fan should start spinning.
In case the fan doesn’t spin at all, then its either a power issue with the psu or a dead board.
But since both are new, that would be a little bit unlikely.

Yeah they can easily seem in for modular cables, thats the biggest downside of them

1 Like

It was the power input on the rear of the PSU. It felt firm and needed a rather hard push to go in deeper… I guess I wasn’t used to that since I don’t buy new hardware that often and usually it goes in smoother.

1 Like

Ah okay, can happen.

Wasn’t that far off in regards to the power cables then haha. :smiley:

1 Like

OP if you want this reopened let us know but since its solved im closing the thread