Two big questions

two questions

  1. my current gpu is the gigabyte 1660 super oc 6gb version

an i currently using the nvidia-driver-470 (proprietary) version
what the diff between it an the 495 (proprietary) version an should i be using it instead

  1. how do i permanently set the cpu priority for cups

to normal instead of the default of very high
so i dont have to set it to normal on ever bootup

my reason for needing to set these cpu prioritys to normal is thers no performance benefit for my pc at
very high but if any are left on very high i get a lot of stuttering an random cpu ramp ups when at idle or light load

setting to normal fixs all that but its very annoying to have to set it manually every time i or my father boots up the pc . what do i need to do in
what config file in pop os to make the settings permanent

470 or 495 are both old ;p Use 510

Pipewire needs to die in a fire (set nice levels, you will need to script it with session start or something similar) You could just uninstall the pile of flaming dog poo then there would be no pipedumpsterfire to cause the issue.

You never said what distro you are on so “what file” can’t be answered since we have no clue what your init system is.

in regards to the nice levels what number would be like a normal cpu priority setting vs a very high one
all my current pipewire config files have the nice levels listed as

        #nice.level   = -44
        #rt.prio      = 15
        #rt.time.soft = 200000
        #rt.time.hard = 200000

what should i edit this to ta get a fixed cpu priority of normal at boot in pop os 21.04

Nice is inverted -15 high priority 15 low i.e. 0 is your middle.
rt at 15? That config is either on crack or Pop_ has implemented some new crap.

Honestly unless you have a dependency removing pipewire is best. I’m an audio engineer and Pipewire has just shown it’s an immature, unneeded bag of crap. Until it’s a hard dependency for “everything” my default suggestion is just REMOVE IT. I mean hell your post is a testament to my point.

I hope you moved to the 510 drivers too :wink: That said I’m not sure how behind the Pop_ repos are.

Thinking about this I also noted Pop_ is implementing it’s own scheduling so maybe that’s why the nice levels in that config seem whack. I’ve also not asked why you wanted to adjust CUPS on boot but it might be part of this scheduler change too that it’s chewing your machine up.

i notice if its set to very high by default sometims i gey random cpu load spikes that drive my temps way up
with some stutter an if i set to normal i dont that way an if i could config to lock that in on boot that would be great

CUPS is a weird system. I have watched it be inconsistent for well over 20 years. I also noticed it was hella broke (again) on 20.XX/21.XX of Ubuntu. Which kinda bring in the question are you printing or scanning and if not why not just uninstall it?

i print an scan about 4 times every other day id just like it not to be so twitchy inbetween use

Ah crappy. Perhaps a less brutalist but equally functional approach would just to kill it until you use it. i.e.
systemctl disable cups ; systemctl stop cups then start when you need it. You could maybe cheese the start command into your shortcut for whatever you use for scanning / printing. So any time you launch libreoffice, systemctl start cups, open gimp…systemctl start cups. When the matching program exists kill cups. Little wrapper script could do the trick.