Tumbleweed AX200 wifi no module? [SOLVED]

I have installed openSUSE Tumbleweed on my desktop PC but I cannot connect to Wifi. The hardware gets detected - the Intel AX200 is listed in hardware report - but I cannot access it at all.

Anyone have any ideas? Ive tried liveCD’s for Fedora, Manjaro, and a couple of others all with the same issue. My two ethernet ports are detected but I cannot use a wired connection for this pc.

AX200 should work, it’s what my board has, been using Manjaro for a long time and Arch/fedora see it / have it accessible, In your uefi/bios is it explicitly enabled or set to “auto”

it should use the “iwlwifi” driver

lsmod | grep "wifi"

to check if it’s loaded, mine shows:

iwlwifi               491520  1 iwlmvm
iwlmei                 53248  2 iwlmvm,iwlwifi
cfg80211             1089536  4 iwlmvm,iwlmei,iwlwifi,mac80211

Could also be possible that you’re missing the linux-firmware package?

lspci -nnk | grep -i "network\\|wi-fi" -A 3

Should also list it and the driver it’s using, i get:

06:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
        Subsystem: Intel Corporation Wi-Fi 6 AX200NGW [8086:0084]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

and the follow should report any errors or messages via dmesg relating to the iwlwifi driver

sudo dmesg | grep -i -E "iwlwifi"

You can throw them into the terminal they don’t do anything just report information.

the driver is supplied by intel but it’s built into the kernel so shouldn’t be anything more you need to do on the OS side of things.

2 Likes

I ended up fixing it

What happened was that a previous install of Win 11 locked the firmware of my wireless card and prevented any non windows system from interacting with it. I thought that this was only an issue for dual-boot systems but apparently Windows is even more shit now…

I had to reinstall windows just to prevent it using the wifi card and then reinstall tumbleweed which fixed it.

2 Likes