Trying to setting up my own Multisite Unifi Controller in a Ubuntu VM on FreeNAS

I am trying to set up a multisite controller system because my brother is not good at anything tecky but wanted to go with a system like mine so he didn’t have to worry about comcast nickel and diming him to death.

I am running an Edgerouter 4 with 3 unifi AP’s in my house. I run the Unifi and UNMS controllers on a FreeNAS Ubuntu 18.04LTS VM “desktop version” and the system works great. I pay for 400 down but i have never seen the system actually get less then 410 down.

I had him get and Edgerouter X and 1 AP (smaller house). I want to just add his equipment to my controllers so i can take care of updates and settings for him so he doesn’t break anything.

I found and signed up with a dynamic IP address service. and set up port forwarding on my Edgerouter.

I set up everything at my house. He is on a 192.168.2 network and everything worked great. I went and installed it and it picked up his internet perfectly. I then logged into my home computer and when i went to the controller. It shows his equipment is disconnected. I now am not sure what to do.

When you did the set-inform, did you use your external public IP address? Or did you just rely on the automatic discovery, which likely used your private internal IP address.

tl;dr do the set-inform / adopt process again, from his network to your public IP.

1 Like


What do you mean by set-inform.

It was attached to my network and the Unifi program saw his access point attached to his router which had an internal ip of 192.168.2.

On his router i used the UNMS key to attach it to my system.

If you could walk me through that a little that would be great.

Maybe this can help:

1 Like

ok thanks i’ll have to read up on this tonight and try to get over this done this weekend because it looks like i have to be there to do some of these things.

1 Like

I tried everything the Device adoption method suggested to no avail. As i continued my search I came across a post saying that ubuntu my be blocking the ports so i tried opening the ports following the guide here

everything but the ssh. (don’t really need it) everything was accepted.
Even redid my domain and nothing still.

Would a cloud Key be an easier thing to get up and running at this point?

I recommend a site to site vpn tunnel instead of port forwarding.

1 Like

Ok this is the next thing on my list to try.