Trying to RDP into a computer


I’m trying to figure out how to RDP into a remote computer on my home network. I’ve enabled remote connections and RDP on the remote machine and the machine is connected to the network via a LAN cable.

The part I’m having a issue with, is telling whether the computer is actually online.

I can see the computer on my router and in explorer:

however the remote machine does not respond to ping and does not show up on NET VIEW

What are my next steps in diagnosing the problem?

PS: I have a password on the remote machine.

Edit: I have tried to RDP into the machine. It just times out.

RDP does not necessarily enable PING from what I recall. You’ll have to enable ICMP on the Windows Firewall of the remote computer.

Ok, I’ll have a look at that. Any reason it wouldn’t show up in NET VIEW?

The reason I’m trying to get RDP working is that suddenly, TeamViewer has stopped working.

Hm… Lack of DNS server, maybe? I’m sorry I’m not more helpful, been out of the Windows game for a minute :frowning:

My router points to google’s DNS server. So all connections are routed there.

Try making an edit to your hosts file

C:\Windows\System32\drivers\etc\hosts and see if you can make an entry:

IP_Of_Server ServerName

Then run

ipconfig /flushdns

See if NET VIEW brings it up.

Still nothing.

I know it worked due to BDO-SERVER resolving to the IP when I try a ping request.

Maybe this is a silly question. Have you tried RDPing to it? You never said.

Yeah I did. It just times out, sorry for the omission. I have also refreshed the explorer multiple times to verify it’s still there.

Is the firewall open for 3389 tcp and udp?
also just making sure even though you mentioned it,
the enabled RDP should look like this:

Mine is only greyed out due to group policy and it is a work machine, but it should still be selected.

Also does the event log give any information that could be of use?

RDP needs both ports 3389 and 3390 IIRC.

Before I suggest something, i’ll need some details.

The remote host is connected to the LAN with an UTP cable, can you verify the cable is plugged in correctly? (not to be a bitch, but this is something that’s easily overlooked)
Then, what’s your network setup like? Do you use a SoHo router, Firewall,…
By default ICMP is active in windows, so I don’t think you’ll need a custom FW rule for that. Can you try:


And check where it stops?

Can you still see the host on the network if you try this in windows explorer:


What windows? Need pro or better.

Edit also ping works on all versions I think your network/firewall is the first place to look. To test you can plug the two directly into each other.

Oh man, you’re totally right. I forgot about that. I think this is what OP might be overlooking.

Opened up the ports and that fixed it thank you :smiley: