Trying to put my new desktop build together for Two weeks

Shadowbane here, Santa was very generous this Christmas, he dropped off all the parts needed to build a Ryzen 3700X desktop build. I have decided to install Pop Os as the only Linux operating software, I have a dual boot system Laptop that runs Windows 10 or Linux Mint, so If for some reason I need to run a Windows program I can’t get to work in Wine, there is the Laptop to run it. I want to learn Linux and at first, I thought a dual boot system would be the best way, but I have found that isn’t the case. I spend more time in Windows because I was too lazy to see if some program that’s Windows-only to run in Wine. So this year I am forcing my self to take the Linux challenge. I have included a list of parts Santa left.
Parts Satna sent
Taichi X570 Motherboard Manual

Now I will get to the point of this post, I am having a few bumps trying to put this build together. Every time I solve one problem two more come up, so after almost two weeks( been trying since Christmas day to put this build together). I still haven’t tried to boot into the desktop Bios to see if it will even post. The current major problems are Santa may have picked the wrong power supply for the motherboard he chose. The problem is the [
SeaSonic FOCUS Plus Gold 650 W 80+ Gold Certified ATX Power Supply doesn’t have a connection for the 4 pins 12v power system that is on the Taichi. Pc Part Picker web site said this wouldn’t be a problem as long as I don’t try to run an overclock on this motherboard. I am wondering if this is true. What is the experience of my other Level 1 peeps? Also, I had another question, The Fractal Design Define R6 case includes a fan controller, my question is how do I get power to the fan controller, and how do I connect the fan controller to the motherboard? I think I know how to get power to the controller, there is a cable that looks like the type used to power SSD or hard drives, I will connect that cable to the power supply, but I still can’t figure out how to connect the fan controller to the motherboard. Can my Level 1v Peeps help a guy out?

Link doesn’t work, says “Permission Denied”. You may have your preferences set to private on PCPartPicker?

The 8-pin and 4-pin connectors are almost certainly electrically connected unless ASRock did something extraordinarily stupid when designing the motherboard. Plugging into just one or the other should work fine. You can overclock just fine on the 8-pin connector as well, the connectors are spec’d for 336 Watts. You’d run into cooling capacity issues before the 8-pin connector became an issue running that amount of power through a chip.

The setup is on page 7 of the case’s manual. There should be two cables coming off of the fan controller, one with a SATA power connector and one with a regular small 4-pin fan connector. The SATA power connector connects to the SATA power connector on your power supply and the 4-pin connector goes to the CPU fan header on your motherboard. Although you may want to plug the 4-pin connector to one of the chassis fan headers instead so you can control your CPU cooler separately from your chassis fans.


Most power supplies don’t have both. This is a non issue. Most plug in just the 8pin.


Thanks, @kdb424 and @w.meri for the advice. I hadn’t planned on overclocking my Asrock Taichi X570 motherboard, at least not until I had another desktop to replace it in case something went wrong. As to the matter of the Define R6 case, I figured I would attach the Sata power connector on the fan controller to the SeaSonic Focus Sata power connector, but I wasn’t sure. When it comes to the small 4 pin fan connector on my case’s fan controller, The instruction was telling me to connect the 4-pin connector to the CPU fan header on your motherboard… the problem with that is the CPU fan header is occupied by a Ryzen Wraith cooler, and the instruction didn’t show any other 4 pins to use. It is nice to know I can connect the small 4 pin connector wire on the case fan controller to a chassis fan header without blowing up anything. Thanks again for the help, it is appreciated.

I will post any updates I have, or if I manage to get my build to post. Thanks again.
Oh, I almost forgot I fixed the problem with my pc part picker build list.

Well an update about my new desktop build, I finally got everything installed except the SSD, hard drive, and the additional fans tried to get it to post, but no luck. I have had it I am taking the build to Micro Center to see if they can get it to work. I learned my lesson, my next desktop build will either design by System 76 or Puget Systems.

Well, I thought I would update my last post, I finally heard back from Micro Center, it’s starting to look like the reason my new desktop isn’t posting is the Ram chips are bad, so hopeful by end of the week I will have it running smoothly. I will wait until I have the desktop up and running before I mark this as solved.

1 Like

I thought I would give an update. I just got my new desktop back from Micro Center, I can now boot into the X570 Taichi UEFI. I talked to the technician who looked at it and He believes the problem was either bad ram or the X570 chipset is still pick about the ram it will run. He replaced the ram with the same type of ram the only difference was the ram that works is rated at 3200 Mhz instead of 3600 Mhz of the old.

Ok, another update, Hurray I finally got my new desktop built and an opertating system installed. Infact I am writting this update with it.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.