Trying to install Ubuntu on an old laptop via USB


While trying to install Ubuntu (I also tried "Try Ubuntu Without Installing", same situation), it tries to boot up and stuff like that, and then it just gets stuck here.

I used the PenDriveLinux tool to help out and I am trying to install Ubuntu 14.04 LTS. Laptop is an old Acer from 2007ish to 2008 with a Pentium T3400 dual core at 2.2 GHz.

Did anyone else have this issue when installing via USB?

Wierd... I have used Lubuntu and Xubuntu both 14.04 on older and new laptops and desktops that went through with no problems.  Maybe there is an issue with the USB drive? Is there maybe something else on the USB drive that can cause conflicts? I also used Pendrive and installed from a Windows Machine as well again no problems. 

I dunno, I tried another USB, but it didn't work. Might be the iso being fucky, that's my last guess

In my experience PenDriveLinux doesn't work the best. Look at Win32DiskImager. It has worked every time for me.

I guess we all have our fav tool for the job. Me I like uNetbootin, cross platform and will download the ISO for you if you wish.

have you tried pressing keys on your keyboard? I've found that works in some cases. you might also want to check and see if your bios is set to use ahci. also on some bios boot menus you may need to boot it as a hard drive instead of usb. for what ever reason some pcs can see a usbstick as a hard drive if you install a bootable partition on it.

I once had that problem years ago: installed it on a different machine, swapped the drive back and was amazed that it booted up!  Maybe it will not work like that now, but might as well try once you run out of options.


I did this a few days ago, worked fine for me...

I've heard of some computers having issue and making sure to swap uefi with legacy mode in the bios and that will help. Otherwise make sure its formatted on the flashdrive correctly. This video will help if your not 100% sure.  Good luck