Trying to fix faulty jbod

I have inherited a Supermicro JBOD (SC837_JBOD) which is not currently operational.

It powers on, fans spin up to top speed, some blue lights come on the backplanes and that’s as far as it gets.

My instinct is to replace the power board, but if anyone has any experience or tips, I would be grateful for any advice.

It’s a simple machine. There are really only 6 parts:

  1. Power supplies (working fine)
  2. Fans (working fine)
  3. CSE-PTJBOD-CB2 power distribution board (?)
  4. BPN-SAS2-837EL1 backplane (?)
  5. SAS837A backplane (?)
  6. External SAS cable bracket (CBL-0386L) (?)

I uninstalled and reinstalled the power board and it worked for a minute and then not…

No experience with this unit, maybe you have tried these things, but I would be looking at the below.

I assume you are getting failure with 0 disks in the unit.

Have you tried disconnected the backplane power, and maybe signal, maybe fans in various combinations? Maybe problem is localized.

Seems like has redundant power? Does it still fail with each of the power supplies connected individually?

Have you checked the voltages coming out of the power supplies and power distribution board? 12V is probably OK if the fans are working, but worth checking anyway if you are going to check.

1 Like

Your best bet in my opinion is to figure out case by case, which cables and cards do what, how they are behaving, and how they should be have.

It working for a short moment could be, it entering a Error State.
You could try to connect to it and get some Debug output. UART / Com etc.

I once had 5 different server boards, two supermicro X9dri-f, who did develope a dislike for some power-supplys.

The issue in particular was named “power good assertion failure” and was reproducable.

The interesting thing was that it is PSU dependent.
So you could take 2 psus from the same brand, and it would work with the one, not with the other. But the other, would work too with any other board that didn’t have this dislike.

I have no clue what that was or why it happened, but it happened with Intel, Fujitsu and Supermicro Servers, so nothing supermicro specific.

I’m trying to source the power card, l2c cable and power distribution unit. I’m pretty sure it’s one of those.

If it’s one of the backplanes, it’s cheaper for me to replace the whole unit.

1 Like

It’s this cable. The red wire is loose.

How do I fix it? Solder somehow (not my forte)? I could probably get the necessary pressure applied with some electrical tape, but that’s not great.

I’d just replace the power distributor (PDB-PT837-8824) but it’s hard to find. I wonder if I can adapt any of the other power plugs to this one. I have no idea what this is though…

You can pull the pin out and crimp a new end on it, its probably the same ends that go on fans.

I doubt the pin is bad tho, even if its loose it should make good contact unless the crip is really bad on that pin

1 Like

I’ve never taken one of these apart before. Is there a good visual reference for how to do this?

It’s about twice as big as a fan power cable.

1 Like

That was very helpful, but idk. The red wire is loose, but the crimped end doesn’t move which makes me think that the red wire has become detached from the crimp.

I’m afraid that if I pull it out, I won’t be able to put them back together, so I’m going to try and super glue it in and then cover it with electrical tape… at least until I can get a replacement part in…

Worst case, I can cut off the end, strip it and tape the wires to the pins.

If all of that is the stupidest thing you’ve ever heard, let me know.


Told you it wasn’t likely

1 Like

It was the power distributor. I replaced it with one from another unit. Now need to order a real replacement and return 2nd unit.