Troubleshooting help windows 8 install [unsolved]

Hello I'm upgrading my current pc motherboard and cpu and I'm trying to re-install windows 8 from scratch (via usb). I can get in and out of the bios fine and I get the windows 8 loading screen when I boot from usb then after about 10 scs it just goes to a blank screen.

motherboard: Gigabyte GA-Z97X-Gaming 3
cpu: i5-4690k
graphics card: Gigabyte GTX 660 Overclocked Edition 2GB
ssd I'm trying to install on: 128GB SanDisk Ultra Plus 2.5" SSD
PCU: 850W FSP Aurum Pro Modular
stroage HDD: 3TB Seagate Barracuda HDD 7200 RPM

Thanks for the help

How is your monitor plugged in? direct to the motherboard or GPU?

Yes it's plugged into the Gpu via DVI-D and my other monitor is plugged in VIA HDMI

I would try direct to the motherboard and see how far you get. Its possible the motherboard needs a BIOS update to run the GPU correctly. Sorry I might be leading you down the wrong path to fix this but its like shooting at a target in the dark, one step at a time.

I plugged into the motherboard directly and when i try boot I get nothing on my monitor not even the bios

The GPU might need to be removed as some motherboard will disable the on board displays when a GPU is detected.

ok so I got to the same spot windows 8 logo loading then blank screen

Ok I pulled this from what might be the same problem. The possible solution below did not work for everyone but might fix your issue.

After rebooting, when I got back to the black screen, I connected a second display monitor, which showed me the picture.
I worked my way from there by:
4. Double click on "Intel(R) HD Graphics"
5. under Driver Tab, click on "Roll Back Driver"
That should solve your problem.
Apparently, after successful installation, Windows 8 updates the drivers in the background, that's why all of a sudden, the screen goes black.

I tryed connecting my second display but still nothing unfortunately I don't get as far as he did I only get to here and then blank screen

Can you boot back into your previous OS?

When I booted from my old windows 8 I just got "Preparing automatic repair" black screen

update: I booted it off my old HDD for a second time and it was stuck at the loading screen for like 5 min, then changed to Getting devices ready and not it's been on "getting devices ready 100%" for about 7min

Try the following: If you can burn the ISO to the usb drive again I recommend doing it. Try booting to a different physical USB port on the motherboard (make sure its usb 2.0, 3.0 can be finnicky), Try installing without your GPU installed, Try booting the USB drive on a different computer, Try creating a ubuntu disk and see if you can boot to that (trial mode). Let us know what you see after these suggestions.

ok I tryed useing the usb to boot on my laptop and it worked but it's now moved to "getting ready" so I think I'm going to wait it out and see if it will just boot giving it a few hours then if not I'll try ubuntu I also tryed useing my windows 8 dvd to install lastnight and that didn't work all with/without gpu installed it's (currently out )

Do you have anything plugged into a USB 3.0 port?

ok tryed everything nothing to do with windows worked but I installed ubuntu and it's working

ok I installed it and it said install sucessful but now it wont boot into desktop just says insert boot media in selected boot device and press any key

Update: just randomly I started it and I got to the install screen but it wont let me install on my ssd says "windows can't be installed on drive 0 portion 1" and it says it can be installed on my HDD but when I try to install I get error code "0x80300024"