Return to Level1Techs.com

[Troubleshooting][Fixed] Overclocking i7-6850k on Linux


#5

My scheduler is CFS. I also tried using MuQSS but it yielded the same results. I don't know if my EFI does custom p and c state stuff (c-states are off as well). Is there a way to check? Yes, I'm on the most recent UEFI version for my mobo.


#6

There will be some feature describing it, Asus calls it "custom OC power states," other manufacturers do similar on some of their SKUs.

Honestly, I'm a bit out of my depth here, I've never experienced this on standard kernels with up-to-date software

They pushed 4.10 just a few days ago iirc, it may be a regression?


#7

I can't find any such features. 4.9 also had the same issue. I haven't tried 4.8 or anything of the sort so maybe installing the old 4.4LTS kernel will yield some results. IIRC, I didn't experience these issues with my overclocked 4770k in Linux. I guess I have more testing to do.

Update: the 4770k overclocks perfectly on Linux.

Update 2: Sorry for the bump, but the same issues exist in the 4.4 kernel. Anyone willing to post their stories and numbers from overclocking a Broadwell E CPU beyond the Turbo Boost 3 clock and running Linux?


#8

I saw the same thing under Antergos with Kernel 4.10, the system runs at stock - permanently - and ignores all overclocking settings in the bios. I am running the 6900K on a gigabyte ultra gaming. The interesting thing is under Ubuntu, kernel 4.8.42, this problem does not exist. I don't think this issues is down to the hardware.

I investigated p-state, upgraded the bios, recompiled the kernel to no avail. So have moved back to KDE Neon under ubuntu running the older kernel. I have only seen 2 other posts about this (including this one) which leads me to wonder if this is limited to the broadwell E line of CPU's.


#9

Thanks for checking this out! You just saved me a nice wad of cash. I just tried using the old 4.8.13 kernel on Arch and everything runs at stock. I'll try to reproduce your results on my machine. Are you running Ubuntu 16.04 or 16.10?


#10

I have switched back to Antergos, as the latest Kernel update solved this issue for me on mine. But I was using Ubuntu 16.04 on the KDE Neon distribution previously


#11

glad to hear it.

some stuff just stays "broken" on canonical's end in my experience.


#12

That's weird, I updated my kernel and nothing happened. You're using the 4.10.5-1-ARCH kernel right?


#13

4.10.4 - Just updated to 4.10.5 today - will see if it breaks it again.

UPDATE: Still works fine on 4.10.5


#14

Bump. I'm also experiencing the same probiem with Ubuntu 16.10 (kernel 4.10.10-041010); I'm still stuck on my stock speed.

Has anyone found a solution ?


#15

I haven't found anything. I've been testing on each kernel update from 4.10.5 to now 4.10.11-1 on Arch.


#16

what scaling governor are you using?


#17

Linux will report the TSC, which is always the default stock frequency. Depends on the CPU how to get the correct reading. On Intel, you would normally dump the MSR's. If you overclock in UEFI, your CPU is overclocked, even if it is not reported as overclocked in linux, or if it is falsely reported.
There used to be a program called turbostat that would compare the actual timings of an ongoing full workload, and calculate the actual speed per core in comparison to the TSC. I don't know if that still exists though, nor if it's compatible with modern CPU's.


#18

sorry but you are wrong.

Ubuntu doesn't take care about what I put in BIOS. For example, I set an amazing value ("80") in "CPU multiplier", Ubuuntu booted without a hitch.


#19

I'm using a Z170 ASRock board, the C-states on mine are in advanced under CPU Configuration.

Overclock reports fine for me on the 6700k in Linux Mint 18 on Kernel 4.4.


#20

I had the same problem and after searching for months, I tried to disable the intel microcode. This seem to have solved my problem on a 6900x


#21

Thank you! This fixed the issue!


#22

damn !! thank you so much ! fixed


#23

Hi timitch, I have i9-7960x and it seems to have a very similar issue in Ubuntu 16.04.4LTS. I wonder if disabling intel microcode is a safe thing to do since Skylake processors and Kaby Lake processors have hyper threading crash bugs. Did you encounter any issue after disabling the microcode?


#24

I wonder if disabling the microcode has triggered any hyperthreading bug on 6700K since it is affected by that errata as it’s a Skylake processor. Currently my 7960 doesn’t overclock no matter what I do. I figure it might be due to the same reason.