Return to Level1Techs.com

Trouble Using Internal Drive, Previously Used for Extra Storage in windows, in Linux

Hello all,

problem: the SSD I previously used for windows storage will not allow me to make or delete files, unless through the cli (specifically when inside the mounted drive, clicking “new folder” or any of the file creation options I get a message telling me I cannot create file in [drive location] /dev/sdb)

  • I have tried: wiping, formatting to ext4, fsck, then reformatting
  • it can mount and unmount properly
  • cd into the drive and mkdir will make a folder inside

Questions:

  • have I broken my drive?, and if so is it recoverable?
  • is there a specific process for this kind of situation, like “wipe, de corrupt/clean, format”?
  • What file system does it currently have on it?
  • When you formatted it to ext4, could you make changes to it then?
  • What OS are you currently running?

depending on the stage of drive management sometimes it has a lost+found, sometimes nothing (was only used for extra game storage, never had an os), yes, the mkdir worked when I formatted it in ext4, debian 10

for a little more context (VFIO project) you can check out the VFIO thread its the first one in there

How old is the drive, do you have S.M.A.R.T data available?