Trouble installing android SDK to get android studio working properly on 64 bit linux mint 17.2

So I have installed android studio, but in order to get android studio working properly I have to install the android SDK. I have tried on my own and also tried to use this tutorial>>http://tutorialforlinux.com/2015/07/03/how-to-install-android-sdk-tools-on-linux-mint-17-2-rafaela-lts-32-64bit-easy-guide/
that I found when googling the issue. Yet no luck. Everything runns fine untill it comes to relocating the SDK (step 5).

I have tried the following commands but all I get is no such file or directory:

chown -R root:root /tmp/android-sdk-linux*

chown -R root:root /Downloads/android-sdk-linux_x86-1.6_r1

chown -R limeman:limeman /Downloads/android-sdk-linux_x86-1.6_r1

chown -R limeman:limeman /tmp/android-sdk-linux_x86-1.6_r1

What am I doing wrong?

Thank you in advance for any help!

uhm

well just extract it in your home folder and run it?

see here https://developer.android.com/sdk/installing/index.html?pkg=studio

also install the 32bit packages required

in terminal

sudo apt-get install ia32-libs lib32ncurses5-dev lib32stdc++6

I have already done that, but in order for android studio to work properly I have to install the android SDK which is not included in the folder that is downloaded for android studio.

just download the package from here https://developer.android.com/sdk/index.html , extract in home and follow the instructions mention before, launch the studio and later you can access the android SDK manager from the studio.

Could you post a little more details? Is there a specific error message you're getting? Simply installing the SDK isn't enough, within the IDE you also need to specify the location of the install.

the sdk is included with android studio, did you not follow the instructions? https://developer.android.com/sdk/installing/adding-packages.html

So in Step 5 of that tutorial, it looks like you are changing the permissions first:
chown -R root:root /tmp/android-sdk-linux*
chmod -R +xr /tmp/android-sdk-linux

Then moving the files to the correct folder:

mv /tmp/android-sdk-linux* /opt/android-sdk-linux

It looks like you didn't download the files to the correct folder to begin with, which was step two. If you did, then the commands in step five, to change the permissions and copy the files to the /opt/ directory, should work properly. Let me know if you need more help.

Thanks man! Problem solved! :)