Trouble formatting SSD; it wont let me make any changes!

I'm having some difficulties formatting my SSD (Kingston hyperX 3K ssd - SH103S3/120G) in order to install linux on it. I'll be installing Arch, and since I'm using UEFI I'll want to use GPT.

However, after trying both manually and through magic parted - no changes are really made. Some of my attempted steps can be found on the thread here. The magic parted logs comes up with;

GParted 0.21.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2

Create Primary Partition #1 (fat32, 513.00 MiB) on /dev/sdb 00:00:00 ( ERROR )

create empty partition 00:00:00 ( SUCCESS )

path: /dev/sdb1
start: 2048
end: 1052671
size: 1050624 (513.00 MiB)
clear old file system signatures in /dev/sdb1 00:00:00 ( ERROR )
libparted messages ( INFO )

/dev/sdb: unrecognised disk label

Create Primary Partition #2 (linux-swap, 3.97 GiB) on /dev/sdb

Create Primary Partition #3 (ext4, 107.32 GiB) on /dev/sdb

I've tried formatting, I've tried secure erasing, I've tried repair functions through gdisk and parted in (when automatically prompted). And now my "last resort" magic parted can't do it either - even after secure erasing and starting fresh. Anyone out there with a clue? It's as if the universe is trying to force me on windows (which I can install without a single hdd problem at all).

Anyone? " /,