Return to Level1Techs.com

Transferring large files nukes system performance

I’ve found a way to utterly ruin my computer’s performance: transferring large files via FTP (specifically, I use WinSCP with the transfer rate cap set to 8192 KB/s). I do not know the threshold, but I know it is >16 GB, as I transferred a 16 GB file via FTP without issue earlier today.

I have noticed, first after transferring a 27 GB file via FTP and more recently a 23 GB file, that the system slows down significantly during transfer and continues to do so long after the transfer ends, only being alleviated by rebooting. Chrome will randomly freeze, network connections will randomly drop (IRC, electron apps, Steam, browsers, etc), VLC will struggle to play a small WAV file, MMCs will take multiple minutes to load, etc. And it only gets worse - within a day, if I do not reboot, I will be faced with catastrophically bad performance, with even task manager taking upwards of 5 minutes to load, despite the system load as reported by task manager rarely being >30% on CPU, GPU, RAM, and all disks.

Does anyone have any idea why this happens? Is it just time to reinstall Windows?

Edit: specs, for those who might be wondering:

  • Win 10 Pro x64, build 2004 (though this happened with 1909 as well)
  • R7-1700
  • 64 GB RAM
  • GTX 1070 Ti
  • A mix of 3 SSDs and 1 HDD; the files were being saved to an HGST HDN726050ALE610 (5 TB HDD)

I haven’t tried unlimited speed in WinSCP because each time I’ve been watching a youtube video while transferring files and didn’t want that to get interrupted.

I use WinSCP on my Windows VM without issues, but have NOT transferred any files larger then about 300MB in size.

I set the speed to UNLIMITED without any issues.

I will have to try larger files and see if this bogs things down.

My workstation is a Threadripper 2950x with 64GB of RAM.

The HOST OS is Windows 10 Pro and the VM I use for work is a Windows 10 Pro with 16GB allocated and 8 CPU cores.

Install Linux… :wink:

1 Like

Is it just when using WinSCP? Have you tried other programs like FileZilla for example?

I have not tried with another program. I am trying with FileZilla now, will report back when it finishes.

Update: This also happens with FileZilla. However, copying the same file to/from a network drive via Windows Explorer does not cause my system to grind to a halt.

Are you an admin user or an unprivileged user?

I am the admin and only user. No domain setup.

This is quite a long shot but that’s what I can think of for now: I think there’s an issue with the LAN drivers. I’d try to reinstall them from scratch (as much as possible obv.) and see if the situation improves.

Or, before reinstalling the LAN drivers, I’d increase the Rx buffer from the configuration page of the LAN adapter you’re using and maybe enable jumbo packets.

A bit of a late followup/bump, but I found something interesting today:

Transferring large files from FTP onto my G drive (a Samsung 850 Evo 1 TB) causes the horrendous performance degradation, but transferring to my C drive (an HP EX950 2 TB) does not.

I know the 850 is in good condition, so this is probably a Windows problem. I’m planning on reinstalling Windows in a week or so, will report back with whether that fixes the problem or not.

What motherboard and what SATA slot is the 850 connected through?

Can you try that drive in another system to see if it happens there too?

I have a Gigabyte GA-AB350-Gaming 3 motherboard. The drive is hooked up to SATA0.

Reinstalling Windows seems to have worked. I can copy 30 GB files via WinSCP multiple times and not a hint of a slowdown beyond Windows’ natural performance degradation.