Torch Browser Won't Install In Windows 10. Can Anyone Help?

Well, today has been an interesting day… Earlier, I uninstalled the Chromium-based Edge so that I could try a few other browsers which I hadn’t yet. I decided I wanted to try out the Torch browser, but I can’t get it installed! So the pc I’m using is a custom-built Windows 10 machine running version 2004. (After doing some research & digging around, I have been able to determine that the Torch browser IS technically Windows 10 compatible; the iffy part as far as compatibility goes is actually the built-in torrent stuff which may or may not working depending.) But from what I can tell, it looks like the issue with me trying to install it seems to be related to apps, Windows Security or Firewall, etc. Though oddly enough, I have been able to install other software WITHOUT this issue!

I haven’t noticed any issues or errors for quite a while, but I am getting 1 as I try to run the installer. (A screenshot showing the exact error message will be included below.) Also, this rig of mine is perfectly up-to-date, running the latest drivers & after checking, my OS & files aren’t corrupted. I’m also the only administrator user. If any of you need more info or have any other questions for me, do ask & I’ll get right back to you! :slight_smile:


Thanks in advance to anyone who can help!

Hmm, that is interesting. Can you move the installer to another folder and try to run it again?

Wouldn’t do any good anyway since I also tried the offline installer with no success. I also tried disabling the Windows Security stuff to see if that would resolve the issue, but it didn’t. Someone on the LTT forum (& also the Microsoft agent I was with) both suggested/suspected that I ought to try re-installing Windows to see if that would do anything. But to me, it would be rather pointless since my OS & system files don’t appear to be corrupted anyway.

I’d check the download isn’t corrupted. If the package is signed and the download broke then the digital cert won’t match on it.

Maybe check the SHA sum on it; if you already did that… well, I’d just use Brave :smiley:


Well, the download is perfectly legit as I downloaded it earlier from the official site. But after looking over the properties of the installer, I don’t have Special Permissions as an admin added. Would enabling them possibly fix this or does it depend?

might be a longshot but did you try right click>run as administrator

actually try and install other programs like 7zip and chrome just to see if it can
what kind of virus/malware protection do you have
avg and avast are the salt of the earth and have caused these kinds of issues in the past

I did try running as admin which didn’t make any difference. I am able to download & install other software without any issues period. As for my virus/malware protection, I’m just using Windows Defender/Windows Security. (I haven’t tried adding the Special Permissions to my user account yet simply because I suck at doing that stuff. LOL Might have a Microsoft Technician do it for me.)

I was also facing the same problem. Just save the exe file in any drive other than C: n then run it. This will solve the purpose. Cheers !

Hi there, this solution will definitely solve your issue since this is a matter of windows security:
Go to settings > update & security > windows security > open windows security > apps & browser control > exploit protection > exploit protection settings > system settings > Data Execution Prevention (DEP) > choose: Off by default

Try right clicking the install folder or exe and uncheck “block files” and click apply. Some installers need it