Tired of my SCP enabled PS3 controller disconnecting

So a while back, someone helped me in deciding which controller i should buy. I settled for using my PS3 controller with the help of some drivers.

Thread - Xbox One Wireless Controller.. DA PHUQ?

Post 5 - @Giulianno_D Suggested the SCP drivers. They worked great for a while… but i don’t know why things like this happen. It started a couple months ago, honestly. I’ve been having this problem for a while but have gotten sick of it. I keep unplugging and replugging in my controller. It just randomly disconnects. It’s irritating. When i first set this up, it worked like a CHARM on GTA Online and MGSV. Now… not so much. It really likes to disconnect when i use my keyboard or when i open up the Steam overlay. WTF?

There any way it can just WORK reliably? Using Windows 7 Pro 64bit.

Have you tried reinstalling the driver from within scp? Every now and then it stops detecting the controller for a me and I just have to reinstall to get it going again.

Are you connecting through bluetooth?

Back when I used to do this I used the MotioninJoy driver with BetterDS3 for configuration and this worked perfectly fine.

If your driver doesn’t work, you could try that.

Note: I used only USB cable back then, so if you’re using Bluetooth YMMV.

I’m having similar problems, but with the DS4 and InputMapper and DS4Windows.
InputMapper can’t activate exclusive mode and DS4Windows keep duplicating the controller on the system until it doesn’t work anymore.

I guess the best option for PC, as of now, is an Xbox One native controller…

Using Gnu/Linux or MS Windows?

On Steam OS and Gnu/Linux, steam detects the PS3 and PS4 controllers. Since the driver for the contollers is in the kernel, you don’t need input mappers.

I don’t if Steam on MS Windows detects and configures PS contollers. If it does, that may be where the issue lies.

I’m on W10 and it works, but the problem lies with games outside Steam, every now and then i want to play a game on Uplay or Origin and i need some Xinput wrapper.
Some games like RotTR natively support the DS4, i’m not shure about the DS3.

Ah. I see. I wonder if the open source driver could be ported to MS Windows.

1 Like

interesting you mention the Steam overlay specifically, are you in the Steam Beta or have you ever messed with Big Picture and its controller compatibility thing, it might be trying to take control over the PS3 controller thinking it is an xBox 360 one.

Just tested the Steam controller thingy again and damn is it working fine, does it work wireless too?

Edit: Holy crap, it does! But my bluetooth adapter is pretty much pure crap…

1 Like


Have you tried adding those games to steam library as external games? Maybe that works?

btw about the steam controller remapping… funny thing is I can’t get it to recognize my Xbox One controller properly :man_facepalming:

I guess i should try that out and see if it will work, i hope it does!

Hmm, weird behavior, is it a new version (from the S model) of the controller or an older one? We tested an older one from a friend and it works fine…

The original, bought it waaaaaayyy before the One S was a thing.

I think I got it to work at some point but with the Steam remapping there seems to be no way of remapping the Xbox button which I use as push-to-talk key when I use the gamepad. Antimicro does this (though there is a bug in the SDL library where the default behaviour isn’t supressed).

Hell naw. Wired, always. Maybe an overcharging problem. I don’t fuckin’ know at this point.


UPlay?! OMG! Please, PLEASE help me out. I want to catch up on the Splinter Cell series. Been looking to get the Splinter Cell Ultimate Edition as i guess it’s my best option. I wanna play all the Splinter Cell games. I’ve only ever played the first one. I know Ultimate Edition uses UPlay. Can you find out for me if i can use my PS3 controller to play all the Splinter Cells? I wanna play these classics, finally. And i sure as hell wouldn’t mind playing the first one again on PC for the first time.

The steam controller API also supports “generic controllers” but I am not sure what exactly that entails. Could be just generic 360 pads but it does also support the ps4 controller and an actual option. The ps3 and ps4 controller both default to direct input devices with out drivers.

So it might be worth trying uninstalling the SCP stuff, fire up Steam Big Picture go to the controller settings and enable generic controer support and see if it works then. Failing that try ps4 support? If either of those work the down side is you will need steam running for the controller to work, but the upside is full remapping. The remapping is super powerful under the SCAPI.

Never mind, tried it myself and while steam does pick up the PS3 controller as a generic controller it does not actually work with it. None of the buttons respond.

It does work just fine when used with the SCP wrapper passing it off as a 360 controller and then steam working with it like that, but not direct.

Which version of the SCP drivers were you using?
I used my DS3 with Nefarius’ SCP Toolkit, it worked very well at the time, shame he abandoned development and didn’t add support for the MK2 DS4…

Went digging and there is a way to get the controller to work with the SCAPI and no indie dev drivers, all official Sony and Steam.

It does involve installing another program, but in this case it is PSNow from Sony. It is a way to play PlayStation 3 games on your PC from their hosted systems but that is not the important part right now. It has drivers for the controller from Sony.

You can use it to get full working direct input which steam will then pick up properly, unlike my guessing above, and then you can have at any which way up you please. Seriously I cannot stress just how awesome the SCAPI is.