Thunderbolt 3 passthrough to windows vm


I just have a question and I may need some help with a weird issue with passings through the gigabyte titan ridge thunderbolt 3 card to a windows vm on ubuntu 20.04

Ok let me begin this long story.
On ubuntu in the grub configuration I said vfio-pci ids=xxxx.xxxx then the Id of the thunderbolt controller and it’s corisponding usb controller to isolated them from ubuntu .But here is the thing when I reboot for the changes to take place the vfio driver latches on and the devices is isolated but after a few minutes the device just disappears from the system and when I run lspci -nnk its just gone.

So I tried several methonds of isolation using vfio and pci-stub but nither worked it was just disappearing. But things got even wirder. After an hour I f struggling I just decided to go into virtmanager and assign the device to the windows vm and then when I started the vm the thunderbolt driver on Linux was replaced with the vfio driver and didn’t disappear and I was able to load the windows thunderbolt driver but I still appeared as a attached device in ubuntu and windows.

I don’t have a thunderbolt device at the moment to test hotplug support. But all I’m look for is an explanation to this wiredness. Any thoughts?


This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.