Thunderbolt 3 networking

Hi, first post on these forums. I was trying to establish a thunderbolt 3 network and thought this is the best place to find other people crazy enough to do it :wink: .
I did it a few years ago, just to test it, between high sierra and whatever windows 10 version was current at the time, and it just worked.

I tried it again now, and it seems the driver is broken on Monterey and also on modern versions of windows 10.

  • I tried 2 old mac laptops (with thunderbolt 2 ) , on Big Sur and Mojave, and they can establish a connection.
  • I tested all my cables using a thunderbolt ssd enclosure and they all work.
  • I also tried between an intel mac running big sur with thunderbolt3 to an older mac on thunderbolt 2 and Mojave, using and tb3 to tb2 adapter… and it worked.
  • The 2 new macs on Monterey are both M1, so I can’t isolate if this is broken because of monterey or because of M1, and because of many reasons (unsupported hardware, difficult downgrades on M1, work laptop that can’t be upgraded) I can’t really isolate the issue at least until January.

This is apparently also hosed in windows 10, I tried updating OS and drivers and all I got was a driver error (“This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)” … before it was just hiding the device instead).

Anyone tried this and/or has some hardware to debug the issue and doesn’t mind falling in a rabbit hole with me? :wink:

Intel’s Thunderbolt software/drivers installation package for Windows seems to be pretty broken.

A workaround I’ve been using without any issues is installing all of the various Thunderbolt (Virtual) Device drivers manually (the Thunderbolt networking ethernet adapter is such a virtual device), how to do this is described in a dedicated thread: