Return to Level1Techs.com

Threadripper NVMe RAID


#1

Now that the AMD x399 boards support hardware NVMe RAID, I haven’t seen anyone mention using it in Linux. Is that because it doesn’t add anything of value over software RAID in Linux or what?

Has anyone got Threadripper NVMe Hardware RAID working in Linux? The AMD community post only mentions Windows drivers. Have the Linux drivers made it into the mainline kernel yet?


#2

It’s really onlt for if you ever need to boot off a RAID.


#3

NVMe RAID is awesome. No need to boot off of it to see that.

Particularly if don’t use the Hardware RAID feature and just setup ZFS with a bunch of PCI-e SAS/RAID controller cards.
Those NVMe’s can make for some hella nice cache disks.


#4

I’m doing NVMe RAID on my new Threadripper system…but ultimately just went the usual Linux software RAID route. It’s software RAID either way, just a question of whether it’s being set up by the UEFI or the OS. I did fiddle with the UEFI implementation a little bit but it looked like it might be a pain to get it to work with Linux and the benefits of doing so would be questionable at best. The Linux approach is pretty much always going to be more flexible.

I guess you can criticize the Linux approach for not really being bootable but that seems like nitpicking because you can always make a small boot partition and RAID everything else. Now if you want to boot Windows on a RAID array then you’re going to have to use the UEFI implementation.


#5

Is your boot partition on one of the NVMe devices or a separate one?


#6

Agreed the feature was for a NVMe boot drive array and thats not so needed but useful. Software raid arrays are the latest in drive arrays. I use BTRFS only because I use my PC as the host of my raid array and its easy / flexible.
A nas I would totally do FreeNAS and mirrored pairs on drives in a pool.
On a workstation RAW filesystem speed is something like 4k or 8K video editing might need. I struggle to peg NVMe speeds with my tinkering with one drive.


#7

It’s on the NVMe devices.


#8

Hi all,

Okay not linux, but here is my issue with bootable raid 0 win, maybe someone got an idea what is wrong.

So, tried to create bootable raid array with 2 ssds with X399E-Gaming Strixx. When I wanted to install Win 1809 the array was not visible during the installation at the partition part after the raid drivers were loaded. The ssds were there, but as 2 different disks.
Then tried with Win 1803, here I was able to intall Windows on the array, but after the first reboot I get an error message that: Something went wrong during the installation, or there was some error, therefore please reboot and start over the installation process.
I set the uefi settings to default, still got the same issue.

I tried bios 0807 and 0808 as well.

Any idea what is wrong here?
Thanks.


#9

If you haven’t figured it out already you have to keep going back and applying every driver that pops up until nothing comes up any more during install.