Threadripper 32 core with thunderbolt 3

hopefully you have this working by now,

as im hesitant to suggest updating drivers to intels latest dch version .

but seem like we are running out of options .


may want to do a complete uninstall of the previous drivers before hand .

and when you get the intel driver installed and working lock it down .

also just in case from what im reading this sets up the cotrol through the windows store app, so hopefully you will have access to the windows store stuff.

1 Like

So I installed a new AMD chipset and reinstalled the Apollo software and immediately it worked seeing the hardware from the apollo software… then upon reboot it no longer said the device is attached in the apollo software but did show up on the thunderbolt system tray.

So I did the jumper trick shorting pin 3-5 and that did nothing.
I just uninstalled the last version of AMD chipset drivers and
I was going to reinstall the newest version upon reboot but now its working…
TB connector is still jumpered and not connected to the motherboard but
Afraid to reboot…

1 Like

That does seem like a PNP problem (plug n play)

Put everything on a power strip then shut the computer down, kill the power strip, then turn it all back on.

I had trouble with hotplug as I’ve said but shutting down the PC and starting it up again worked fine for me.

Everything is on powerstrip/power conditioners but I unplugged the Thunderbolt Hard drive enclosure and rebooted and it worked again.
I guess I dont understand…do they need to power on at the same time from power strip being turned off every time? It is some sort of PNP thing now I guess but it still seems random?
Should I go back to directl plugging into the Thunderbolt mother board header?
Because it worked once before without that jumper…

Sure plug back into the Mobo header w/no jumper.

The power strip just resets stuff. For me an egpu enclosure would work once until it was power cycled because the thunderbolt reset was not really happening on reboot. E…g the device didn’t detect that the host had rebooted.

Same as if you hot plug or surprise remove … it wouldn’t work until you sleeped the system/rebooted it.

Otherwise it worked fine.

I think once you get the process down it should work reliably if you follow the restart process. It’s not clear what must be hard power off is actually required but you can experiment

1 Like

I appreciate your help on this but I installed the new Radeon software for my video card and AMDs chipset and it wouldn’t boot my Apollo device no matter how many times I rebooted.
I uninstalled and upon reboot it saw my Apollo device. Until I rebooted.

Soo. I’m still trying to find the right order to make it work and it is definitely a hot plug issue. But it’s not consistent.

Just a follow up and its not perfect but It tends to help that I do a reset on the apollo before I reboot the computer.

i would keep an eye out for a better thunderbolt card , the gigabyte one seems to limited and is most likely the source of the problem.

hopefully one will come out that lets you set it up in a more compatible fashion.

im just really shocked that the gigabyte card has no config what so ever. especially after seeing the myraid of config options of a typical on board thunderbolt chip.

also have you tried that intel driver ?

@Michael_Bailey hey did you find any solutions for this exact same problem? I’m using Titan Ridge on an Asrock x399 with 1950x. My thunderbolt software also works fine but I can’t connect Apollo x8 to UAD console consistently. It works whenever I uninstall and reinstall UAD software. I’m going insane and I have absolutely no budget to buy any sort of Mac so any kind of improvements on this would be a life saver.

Your interface may be saturating that port, and you might not be able to daisy-chain.

Maybe having multiple cards and dedicating one to your interface and one to your Thunderbolt HDDs?

I really wish Windows didn’t EOL FireWire, because it’s audio production people that suffer the most because USB packets aren’t as reliable as a FireWire stream.

Michael I built almost the exact same system, except i’m using the 2970wx seeing as Ableton Live with only use 32 threads on windows. Didn’t have much luck with thunderbolt when i built it and just removed the card. I built this machine with Red-net in mind, and so far i have managed to get my Dante network configured with a mac i borrowed. I still have my Titan ridge though and i have been waiting for TB development to progress before i attempt putting it back in my rig.

I discovered some interesting things about the Threadripper while working on an overclock, Specifically regarding the SOC. First off the faster your Ram the faster the processor will preform, up to 3200mhz after that its diminishing returns. Second is if you are using XMP profile ram, you need to boost the Vcore SOC voltage by .05 or .0562. this will stabilizes everything regarding the Chipset. I saw drastic benchmark increases in cinebench after that adjustment.

you need to go to M.I.T. in your bios , and then advanced voltage settings. Raise Vcore SOC to 1.15 or 1.156
Also you need to set SOC load line calibration to standard.
The page up and down keys will allow you to change settings.

Try that out and tell me if there is any change in TB performance.

Also With a Custom water loop you should be able to push that threadripper close to 4 gig. If you plan on doing that hit me up, ill link all the parts i use to build my loop.

1 Like

Hey Guys,
So Ive been workinf for 5 months using the system until I updated my Thunder Ridge Firmware Drivers to the newest version.
Now it will not see my Apollo Converter.
Anyone know a way to reset the Thunderridge Firmware back to factory? On gigabytes site they do not have the older version available for download. I do have the CD the PCI card came with but do not see a firmware installer of version 1… uggg soo wish I would have left it alone.

Intel probably fixed whatever bug that was allowing it to work on an unsupported system?

Buy another card, use the firmware tool to download that firmware? Or maybe another kind soul here would do the same?

This is what I was thinking as well which is why they dont show backwards compatible files on the site. This is a huge problem for me. Thanks for the input. If anyone can help Ill be eternally grateful. I have sessions that depend on it.

Anyone know of a better thunderbolt PCI card to use over the gigabyte titan ridge? I thought I would try the Alpine Ridge version 1.

I’m waiting for Intel and the USB-IF to fully release USB 4.0 before investing in any sort of add-on card… well that, and I don’t have any hard pressing applications for TB at the moment.

Isn’t Alpine Ridge the older version of TB 3?

1 Like

If USB 4 pci card comes out then you think it will make it possible for AMD Threadripper to connect to thunderbolt 3 devices?
Yes, It is an older version of TB3… I had the older firmware version of the Titan and it worked…

That’s what I hope. I mean it’s a good sign that AMD is starting to warm up to Thunderbolt, they even included it on some x570 boards. USB 4 is supposed to be cross compatible with Thunderbolt 3, so :man_shrugging: fingers crossed!

1 Like

If anyone is interested in purchasing the Threadripper 32 with the Aorus Xtreme motherboard from me I think Im going to go Intel just so I can get back to work. (Not trying to make this a selling site just thought it might be of interest to someone in this convo.

There is a Buy/Sell/Trade part of the forum if you want to post it there.

Sorry to hear it is not working out. It is a huge shame that Intel continue to be dicks like this when thunderbolt is supposed to be a free platform now. Guess this just the last thing they can use to get back at AMD now they are losing market share.

1 Like