Threadripper 32 core with thunderbolt 3

I almost always leave my interface on first and then reboot/power down the computer…not linux compatible.

This is the Apollo X audio interface requirements. It doesnt refer to AMD just intel…would this matter ?

  • Thunderbolt 3 cable (not included)
  • Internet connection to download software and authorize UAD plug-ins
  • 6 gigabytes available storage
  • Quad Core i7 or better processor recommended
  • For additional compatibility information, visit


  • Available Thunderbolt 1, 2, or 3 port
  • Thunderbolt 1 and 2 connections require an Apple Thunderbolt 3 to Thunderbolt 2 Adapter (not included)
  • macOS 10.12 Sierra, 10.13 High Sierra, or 10.14 Mojave


  • Available Thunderbolt 3 port
  • Windows 10 (64-Bit Edition)

The apollo converter works with my macbook laptop no problems…
Will I have better luck going thru the headache of trying to turn my threadripper into a hackintosh?

using this windows tb driver? and the titan ridge controller?

you have both the internal usb and thunderbolt cable in good?

Yes Im using the windows TB driver and the titan ridge controller.
The thunderbolt cable is definitely in good and pretty sure the usb internal cable is in good…what would happen if the usb wasnt connected? Ill check again on the cables.

Oh,…I did put the PCI into 3.0 mode instead of auto in BIOS and it didnt seem to change anything…do i need to change any PCI config setting in bios that the TB card is installed to?
(4x4 or 8x8)

Unplug the TB header from the mobo

Then try this

It’s a jumper cable
With this hotplug is likely out the window so hard reset the TB device when you powr on the system.

And be extra extra careful the jumper is only touching the two pins and nothing else or it could be real bad


No pcie 3.0 is a good idea. Into one of the x8 slots from the CPU.

1 Like

Thanks wendell.
Ill try this jumper trick tomorrow morning. Thank you again for your help.

hopefully you have this working by now,

as im hesitant to suggest updating drivers to intels latest dch version .

but seem like we are running out of options .


may want to do a complete uninstall of the previous drivers before hand .

and when you get the intel driver installed and working lock it down .

also just in case from what im reading this sets up the cotrol through the windows store app, so hopefully you will have access to the windows store stuff.

1 Like

So I installed a new AMD chipset and reinstalled the Apollo software and immediately it worked seeing the hardware from the apollo software… then upon reboot it no longer said the device is attached in the apollo software but did show up on the thunderbolt system tray.

So I did the jumper trick shorting pin 3-5 and that did nothing.
I just uninstalled the last version of AMD chipset drivers and
I was going to reinstall the newest version upon reboot but now its working…
TB connector is still jumpered and not connected to the motherboard but
Afraid to reboot…

1 Like

That does seem like a PNP problem (plug n play)

Put everything on a power strip then shut the computer down, kill the power strip, then turn it all back on.

I had trouble with hotplug as I’ve said but shutting down the PC and starting it up again worked fine for me.

Everything is on powerstrip/power conditioners but I unplugged the Thunderbolt Hard drive enclosure and rebooted and it worked again.
I guess I dont understand…do they need to power on at the same time from power strip being turned off every time? It is some sort of PNP thing now I guess but it still seems random?
Should I go back to directl plugging into the Thunderbolt mother board header?
Because it worked once before without that jumper…

Sure plug back into the Mobo header w/no jumper.

The power strip just resets stuff. For me an egpu enclosure would work once until it was power cycled because the thunderbolt reset was not really happening on reboot. E…g the device didn’t detect that the host had rebooted.

Same as if you hot plug or surprise remove … it wouldn’t work until you sleeped the system/rebooted it.

Otherwise it worked fine.

I think once you get the process down it should work reliably if you follow the restart process. It’s not clear what must be hard power off is actually required but you can experiment

1 Like

I appreciate your help on this but I installed the new Radeon software for my video card and AMDs chipset and it wouldn’t boot my Apollo device no matter how many times I rebooted.
I uninstalled and upon reboot it saw my Apollo device. Until I rebooted.

Soo. I’m still trying to find the right order to make it work and it is definitely a hot plug issue. But it’s not consistent.

Just a follow up and its not perfect but It tends to help that I do a reset on the apollo before I reboot the computer.

i would keep an eye out for a better thunderbolt card , the gigabyte one seems to limited and is most likely the source of the problem.

hopefully one will come out that lets you set it up in a more compatible fashion.

im just really shocked that the gigabyte card has no config what so ever. especially after seeing the myraid of config options of a typical on board thunderbolt chip.

also have you tried that intel driver ?

@Michael_Bailey hey did you find any solutions for this exact same problem? I’m using Titan Ridge on an Asrock x399 with 1950x. My thunderbolt software also works fine but I can’t connect Apollo x8 to UAD console consistently. It works whenever I uninstall and reinstall UAD software. I’m going insane and I have absolutely no budget to buy any sort of Mac so any kind of improvements on this would be a life saver.

Your interface may be saturating that port, and you might not be able to daisy-chain.

Maybe having multiple cards and dedicating one to your interface and one to your Thunderbolt HDDs?

I really wish Windows didn’t EOL FireWire, because it’s audio production people that suffer the most because USB packets aren’t as reliable as a FireWire stream.

Michael I built almost the exact same system, except i’m using the 2970wx seeing as Ableton Live with only use 32 threads on windows. Didn’t have much luck with thunderbolt when i built it and just removed the card. I built this machine with Red-net in mind, and so far i have managed to get my Dante network configured with a mac i borrowed. I still have my Titan ridge though and i have been waiting for TB development to progress before i attempt putting it back in my rig.

I discovered some interesting things about the Threadripper while working on an overclock, Specifically regarding the SOC. First off the faster your Ram the faster the processor will preform, up to 3200mhz after that its diminishing returns. Second is if you are using XMP profile ram, you need to boost the Vcore SOC voltage by .05 or .0562. this will stabilizes everything regarding the Chipset. I saw drastic benchmark increases in cinebench after that adjustment.

you need to go to M.I.T. in your bios , and then advanced voltage settings. Raise Vcore SOC to 1.15 or 1.156
Also you need to set SOC load line calibration to standard.
The page up and down keys will allow you to change settings.

Try that out and tell me if there is any change in TB performance.

Also With a Custom water loop you should be able to push that threadripper close to 4 gig. If you plan on doing that hit me up, ill link all the parts i use to build my loop.

1 Like

Hey Guys,
So Ive been workinf for 5 months using the system until I updated my Thunder Ridge Firmware Drivers to the newest version.
Now it will not see my Apollo Converter.
Anyone know a way to reset the Thunderridge Firmware back to factory? On gigabytes site they do not have the older version available for download. I do have the CD the PCI card came with but do not see a firmware installer of version 1… uggg soo wish I would have left it alone.