ThreadRipper 1950x OC => Windows sleep bug

Hi All,

Over quite a bit of testing I came to the following observation:

  • Overclock my 1950x to 4100Mhz with fixed clock and voltage (1.3.25V)
  • After waking up from sleep in Windows 10 Pro the time is running faster and the FPS in for example World of Tanks is 50FPS instead of 60FPS

I tried enabling and disabling HPET but it doesn’t change anything.
Does anyone have the same problem or advice?

Running on Asrock Taichi X399.

Thank you.

I’m using an ASRock Taichi X399. Updating the bios to the latest (still beta) bios fixed the issue.
Now everything is running perfectly @4100Mhz @1.325V.


Although the sleep bug is fixed, I found that with the new BIOS the bus clock is not stable while overclocking (see [Troubleshooting] ThreadRipper OC on Asrock Taichi X399 broken)

In summary:

  • BIOS 2.0: suffers from windows sleep bug when overclocking
  • BIOS 1.91E (beta): fixes windows sleep bug, but has unstable bus clock while overclocking

I raised a ticket at Asrock hoping they fix the issue.

@wendell any chance you can check with your contacts at Asrock if they are aware that both BIOS 2.0 and BIOS 1.91E (beta) suffer from issues when overclocking? As a result I can only conclude that at this moment overclocking ThreadRipper on a Asrock Taichi X399 is not functional.

This may actually be the result of ryzen master drivers or cstate. Disable cool and quiet then repeat your tests? Uninstall ryzen master?

Flashed again BIOS 1.91E, did a simple overclock to 3.8Ghz @1.325V. Fixed APU/PCIe frequency to 100Mhz (so 38x multiplier).
Uninstalled AMD Ryzen Master, disabled c-states, disabled Core Performance Boost … and still the frequency is jumping up and down in CPUID HWMonitor. It’s harder to notice in HWiNFO64.

This doesn’t happen with BIOS 2.0 … but then you have the windows sleep bug :tired_face:

Cool and quiet is its own setting
That disabled also?

From screenshots of the Taichi X370 there is a separate Cool and Quite option. However on the Taichi X399 I can’t find this option.

All this is not necessary on the BIOS 2.0 though. Only 1.91E seem to have this issue.

1 Like

@wendell my issues with overclocking my threadripper are finally fixed.
Asrock help desk has been very helpful and provided different early BIOS releases. Now happily running BIOS version 2.35.

Very reassuring that Asrock help desk actually listens and helps their customers!