Think I have a BIOS issue?

Just wondering if any of you have encountered this or can tell what my problem is.

I bought an Acer ES1-411-COLT awhile back, and decided to get a HDD caddy for my empty optical bay. Now I have two drives one with a windows OS, the other in the optical caddy runs a newer version of Ubuntu.

I can only run the linux drive in the optical bay if I remove the HDD with windows. If I put both drives in it will only boot to windows. I try to boot from the optical bay in the BIOS or change the boot sequence but it does not detect the drive when the other one is plugged in.

When I am running windows I can use the disk management tool and see that the other HDD is there, but it says the size is 0 and does not have a letter assigned to it. If I right click on the drive all options are grayed out and I cannot do anything with it.

My next step was to try and check for a BIOS update. Is that a good place to start or does someone know a different path? If anyone wants any specific information on my system or BIOS settings Ill get them.


Simply if you installed the two OSs while the other disks were disconnected you installed two bootloaders one on each drive. When the BIOS initalize looks for the bootloader and when both drives are connected, maybe because Windows uses secureboot, the bootloader chosen is the Windows one. You can't assign a letter or mount the Ubuntu drive because it's not using a filesystem that Windows can understand so you can't operate on the disk natively without the support of another software (Minitool Partition Wizard or Easeus Partition Master for example). Updating the BIOS in this case and if the system is stable 100% is not recommended.

Most likely the issue

first do this

Completely shut down your computer.
Power on the system. As soon as the first logo screen appears, immediately press F2 to enter the BIOS.
Use the right arrow key to select Security.
Use the down arrow key to highlight Set Supervisor Password and press Enter.
Create a password and press Enter. Retype the password to confirm and press Enter again.
Use the right arrow key to select Boot.
Press the down arrow key to select Secure Boot and press Enter.
With the arrow key, highlight Disabled and press Enter.
Press the F10 key and select Yes to save the changes and exit the BIOS.

reinstall windows, do not disconnect windows hdd. Install ubuntu. That should fix your issue

Thanks for the quick help and info @MetalizeYourBrain and @jonnytombstone. I'll give that a try and let you know how it goes.

1 Like