Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1964

I’ve been through the entire BIOS/UEFI front to back and there isn’t any mention of Secure Boot. I also tried added ‘nomodeset’ to the kernel parameters. Still won’t display anything after GRUB.


#1965

Looking at the manual, the board DOES support Secure Boot. See page 55: http://asrock.pc.cdn.bitgravity.com/Manual/AD2550RU3S3.pdf

The only other clue is this bug report, which doesn’t seem to prevent booting: https://bugzilla.redhat.com/show_bug.cgi?id=1497559

I’d try disabling Secure Boot…


#1966

What I see is exactly like what’s in the manual screenshot on page 55: there isn’t any Secure Boot option visible. The manual says there is one, and that it is defaulted to disabled, but it isn’t there.

I just set all UEFI defaults and it still doesn’t work.


#1967

On the boot menu, is there an option to boot your USB stick that does not have “UEFI” in front of it? Booting in legacy mode may bypass Secure Boot.


#1968

I really thought that would do it, but it didn’t. Screen still turns off.

Seems to work slightly better with a different monitor. But it’s very inconsistent and flaky.


#1969

Found this in the manual:

Microsoft® Windows® 7 / Home Server
2011 / Storage Server 2008 R2 / Server
2008 R2 and Fedora ( 64bit OS* no graphic
driver support, need to use inbox graphic
driver)

Does it need a special video driver? It says it uses “GMA3600” which I’ve never heard of before.


#1970

That sort of makes sense, then. What does “inbox graphic driver” mean?

Found this: https://wiki.archlinux.org/index.php/Intel_GMA_3600

Not sure how to implement the xorg conf stuff if I can’t even get it to boot right. Or if that would even fix it.


#1971

I’m guessing, but I would think “in box driver” would refer to a driver on CD included with the original motherboard box.

This post refers to the GMA 3650, but may apply to your board: https://communities.intel.com/thread/31745

Can you try booting with a kernel parameter of “video=DVI-D-2:d” or whatever might be appropriate for your video port/monitor? See the thread for some alternate examples.

EDIT: I read the linked thread a little more carefully. Try adding the three separate video parameters listed in the intel.com thread, especially if your board has a single VGA output.


#1972

Thanks for the help. I tried adding those parameters to the kernel, modifying them for what I have. I tried VGA-1:d and HDMI-1:d, but they didn’t work. I might be using the wrong names, not sure.

After some more digging I found that this specific chipset/processor is an abomination. Linux support for the video implementation is not good at all.

I found this: https://ubuntuforums.org/showthread.php?t=2250571 After blacklisting the gma500_gfx module I can get farther along, but I forgot the encryption password. When trying this with the USB install drive it doesn’t seem to boot properly, but it does seem to go further as well.


#1973

Here are some notes on the proper syntax of the “video=” kernel parameter: https://wiki.archlinux.org/index.php/Kernel_mode_setting

It should be noted that the original thread I linked to is for the GMA 3650, not the GMA 3600, so different parameters may apply…

Other than that, I don’t think I’m going to be much more help.
EDIT: On the end of the “video=DVI-D-2:d” parameter, the “d” means to disable the video port, so you don’t want to disable VGA or HDMI, which are the ports you want.
EDIT2: Maybe you should just try putting “video=LVDS-1:d” in your kernel parameters and see what happens.


#1974

Yeah, I saw that in the arch wiki page. I set it how it should be, video=VGA-1:[email protected], and I think I can tell it works better doing that. Still doesn’t work on the monitor I’d like to use, which is weird.

If I have it plugged in to the second, crappy monitor, boot from the install on the SSD, and don’t add anything at all to the kernel parameters, I get this:

Like I said, I forgot the encryption password for the install on the SSD. And the Fedora 29 Server install USB doesn’t seem to work. If I use a normal Fedora 28 Desktop install USB it gets most of the way through boot then gets stuck at a start job for Hold.

I’ve tried booting UEFI and Legacy. Adding the parameters and not. blacklisting the modules and not. Nothing seems to work properly or consistently. I’m halfway considering just throwing this board in a box and forgetting about it.


#1975

Is this a Dell? There’s an issue with older Dell computers where it wont recognize UEFI as a proper boot option, you can fix it by pointing the boot to your grub.efi file manually.


#1976

Naw, it’s an ASRock ITX board with an Atom D2550. Apparently Intel, in their infinite wisdom, decided to use some PowerVR based video solution for that generation Atom/chipset instead of their own.

Doesn’t play well with Linux. At all. I’ve wasted most of my Sunday (and some of @imrazor’s as well, thanks for the help) trying to get this working. Pretty much fed up with it and thinking about getting something else.


#1977

If you set it up in your rc local, it will happen on start up. The link that you provided has procedure mentioned at the bottom. Follow it and you should be fine.

In regards to the difference between 0 and 2. 0 is more than likely the button on your laptop that turns Bluetooth off (see ACPI) while 2 is probably the hardware level where you can prevent the hardware from turning on, period.


#1978

So I have a dual monitor setup and I am running Linux Mint 19.
For the life of me I can’t remember how to print screen a single monitor.

I swear it was arrow key print screen or something like that

The search results I am finding online are clouded with using a program to edit the image…


#1979

Are you using Cinnamon or MATE?


#1980

After updating my fedora partition, it get stuck on bootup. And it wont start gdm.
I can still login into terminal with CTRL+ALT+F2, but then startx doesn’t work.
I couldn’t find any solution to fix this.


This is wat is displayed,

I’m using fedora 29, with the rpm fusion nvidia drivers.
Does someone know how to fix this, or what is the problem?


#1981

I’m using cinnamon. I should of mentioned that to begin with, my bad…


#1982

Having a networking issue.

I have a vm with 2 NICs. One is for network storage traffic (jumbo frame) (ens192 - 10.4.8.0/24) and the other is for everything else (ens160 - 10.4.4.0/22).

The issue I’m having is that Ubuntu keeps trying to use the storage interface as a default gateway, even though the DHCP server doesn’t advertise a default gateway or route and the router rejects all traffic trying to leave that vlan.

Initially route returns:
25

After a couple minutes, this changes to:

07

There is also a long pause when calling route the second time.

Is there a way I can get this to work without manually configuring the host? I’d like to be able to bring up a host with these two interfaces and have it figure out the proper gateway via DHCP…

15

The 10.4.8.1 gateway is not being provided by the DHCP server. Ubuntu is somehow figuring this out on its own. It is the address of the router/dhcp server on that interface but as stated, traffic on the vlan is blocked from reaching any other subnets and the DHCP server doesn’t advertise a default route at all.


This is Ubuntu 18.04, so it’s using netplan which I’m not too familiar with. It does work fine if the 10.4.8.0/24 address is set manually.


#1983

So using console via proxmox webgui… I borked my resolution and im trying to use .xprofile or .Xdefaults to get it to change the resolution back upon login…

nothing has worked so far…

fedora28