Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1944

See above.


#1945

You can umount the drive as part of the script and either use beep or aplay to make noise.


#1946

I’m trying to upgrade to Fedora 29 with the dnf system upgrade plugin, and I’m getting some errors:

Error: Transaction check error:
  file /usr/share/doc/pstoedit/pstoedit.htm conflicts between attempted installs of pstoedit-3.73-3.fc29.i686 and pstoedit-3.73-3.fc29.x86_64
  file /usr/share/doc/pstoedit/pstoedit.pdf conflicts between attempted installs of pstoedit-3.73-3.fc29.i686 and pstoedit-3.73-3.fc29.x86_64
  file /usr/share/man/man1/pstoedit.1.gz conflicts between attempted installs of pstoedit-3.73-3.fc29.i686 and pstoedit-3.73-3.fc29.x86_64

Seriously? It’s choking on pdf, html and man page files?
My first instinct is to remove ‘pstoedit’, but when I look at the dependencies to be removed, I get a little nervous:

Dependencies resolved.
================================================================================
 Package               Arch         Version                Repository      Size
================================================================================
Removing:
 pstoedit              i686         3.70-10.fc28           @updates       1.8 M
 pstoedit              x86_64       3.70-10.fc28           @updates       1.8 M
Removing dependent packages:
 autotrace             i686         0.31.1-50.fc28         @fedora        393 k
 autotrace             x86_64       0.31.1-50.fc28         @fedora        382 k
 fontforge             i686         20170731-5.fc28        @fedora         18 M
 fontforge             x86_64       20170731-5.fc28        @fedora         18 M
Removing unused dependencies:
 libEMF                x86_64       1.0.9-5.fc28           @fedora        280 k
 libuninameslist       x86_64       20170701-4.fc28        @fedora        2.9 M
 plotutils             x86_64       2.6-20.fc28            @fedora        4.5 M\
Transaction Summary
================================================================================
Remove  9 Packages

Are any of these packages critical? Is it safe to just remove the offenders and get on with life?


#1947

I’m no expert but looks like the conflict is in the architecture. Is there a reason you have both i686 and x86_64 versions installed? My first attempt would be to uninstall just one arch.

On Fedora 28, I don’t have pstoedit, autotrace, or fontforge installed, so I’d guess they’re not essential.


#1948

I686 is probably installed for the sake of Steam. I’m not sure if Steam specifically requires pstoedit though. If I remove i686 entirely, I’m pretty sure that will break Steam.

Edit Perhaps if I just uninstall pstoedit.i686?
Edit2: Removing pstoedit.i686 just removed 1 dependency, autotrace. Upgrade in progress, here’s hoping my install doesn’t get borked…


#1949

Yes I meant why have both the i686 and x86_64 versions of pstoedit.


#1950

Any successes or issues in the Fedora 28 -> 29 upgrade? Particularly for those using nvidia drivers from negativo or elsewhere?

There’s this bug about being unable to login with gdm and nvidia drivers, but I use MATE/lightdm…

I’ve also read about some issue with a VLC player dependency package.

I requested the gnubiff copr repo maintainer to build it for F29 and they were gracious and very speedy, so that’s ready.

It’s possible there’s an issue with the oracle virtualbox repo too, but I forget.

Seems like any issues are largely just with repos.


#1951

Hey guys. Recently I made a thread about my crossover monitor not working at 95Hz under Linux. I did a bunch of stuff over the passing days. Tested a bunch of versions of Fedora and Ubuntu. Here is the result:

  • Fedora 28 3-6 months old ISO image: WORKS
  • Fedora 28 updated: FAILS
  • Fedora 29 updated: FAILS
  • Ubuntu 18.10: FAILS
  • Ubuntu 18.04 WORKS

Now I really like how Fedora works and would like to preserve my current system. I am using Vega 64 with open source drivers.

What can I do to try to fix this? or did something change in the newer kernels which for some reason is braking the EDID of my monitor.


#1952

Are you using HDMI, DisplayPort or DVI?


#1953

Well, there’s your problem.

AMDGPU drivers are somewhat fucky with the high refresh rate or resolution.


#1954

I see. So upgrading the kernel on ubuntu 18.04 would not get me anywhere? Next thought.
If I go proprietary, AMDGPU-PRO will brake Fedora when I update? or is it only on version upgrades? I also have a 980ti I could use instead but again proprietary drivers…


#1955

After I upgraded, Wayland flipped out and gnome-shell was pegging my CPU for no reason. Went back to xorg and it’s been fine. Nothing special on it though, just IT and virt stuff.


#1956

Thanks for the report. Which graphics drivers?


#1957

@sceps Thanks for asking. Yes, once pstoedit.i686 was removed the upgrade went smoothly. Even my custom patched version of Wine continued to work - I was afraid some library would get broken or upgraded.

I’ve been upgrading Debian for years and its almost always gone smoothly. I had heard horror stories about Fedora upgrades. This wasn’t as smooth as some of the Debian upgrades I’d done, but honestly it was pretty easy.


#1958

use --best and --allowerasing. DNF gets chocked up with multi-arch systems.


#1959

anyone know how to disable bluetooth autostart on Fedora 29, IE make bluetooth not autostart?

I tried looking up guides, but they were either out of date or they didn’t work
It’s annoying because I forget to turn it off and it drains my battery faster.

sudo systemctl stop bluetooth
sudo systemctl disable bluetooth

tried using these commands, but I don’t want to reuse these commands everytime I reboot
Tried using this, didn’t work
https://ask.fedoraproject.org/en/question/31972/how-to-turn-off-bluetooth-by-default/


#1960

So enabling and setting up rfkill and the rc local to turn that off did not work?

The systemctl commands will only turn off the bluetooth daemon but will not turn it off if you have hardware buttons.

If we are talking about a laptop, there may be a bios setting to turn it off by default.


#1961

Haven’t looked into rfkill, mostly just want a way to have it on standby so if I do want to connect w Bluetooth device I can quickly change between them.

Also if I setup rfkill do I have to rerun the block commands upon restart?

rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

What’s the difference between 0 and 2?


#1962

I decided to upgrade my laptop from Fedora 28 to 29. This is the first time I tried doing it with the GUI Software application instead of command line DNF. It went perfectly smooth, zero problems. Very impressed with how easy it was. I think I started with Fedora 22 on this SSD and have upgraded successively each time.

Now, how about an old fashioned “Linux isn’t booting right” sort of question?

I have an ASRock AD2550R/U3S3 motherboard I am wanting to use for a backup server, but nothing I try boots properly. I think I got it to work in the past, but I forgot how. I have Fedora 25 installed on the SSD, so it must have worked back then. I have tried booting a Fedora 29 install USB as well as an Ubuntu 1803 USB, and everything does the exact same thing:

I get the normal GRUB screen, then it flashes this:


Then the screen turns off. Not a black screen, the computer turns the screen off.

Any ideas?


#1963

My first thought was a secure boot issue, but looking at the board specs I’m not sure it has secure boot since it lists Windows 7 as the only windows version supported. I think secure boot was introduced with Windows 8. But, I would check for secure boot being enabled.