Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1904

Oh no that’s fine I know how to use checkinstall. The permission problems I’m having a related to the permissions required for Qemu. Make install requires sudo and also requires a couple of commands in a row to actually install.


#1905

Nope. I was sure it was going to work though.

I’m still getting this
image


#1906

What is recommended for creating .rpm packages from source for Fedora et al? checkinstall is no longer available from Fedora repos.


#1907

Is that from git? Is that an rc version.

Mine just says 3.0.0


#1908

Is there a way to show the GPU clock speed? Not sure my GPU is clocking up to the correct speed.

I have used “sudo lshw -C display” - But that just shows the downclock of 33mhz
GPU = AMD R9 290


#1909

Fedora would use rpmbuild.


#1910

Hmm rpmbuild process looks quite a bit more involved.


#1911

It’s from the macOs branch


#1912

And the exact same problem and solution upon upgrading to nvidia driver 410.66. Does no one else have this issue?


#1913

Well, if you already haven’t solved this, maybe you can make install and just see what it does on your system (like where it copies it’s files or something) and remove all that. I don’t promise anything, but it might work.

You can also do which to each qemu-whatever in your system to see where are the executables stored and delete them.

Also, not providing an uninstall target is kind of bad, you should file a bug or something to get that fixed.


#1914

Is there still no native VNC server in Fedora with Wayland?

I don’t usually use VNC on Linux but I have an instance where I want to. There’s no option in Fedora 28 under sharing (where I think it was/is supposed to be), and when I googled it there is conflicting info about VNC on Wayland.


#1915

X11 over ssh


#1916

On Fedora 28, sudo dnf update is showing

Failed to synchronize cache for repo ‘virtualbox’, disabling

What’s wrong?

I have the following .repo file in /etc/yum.repos.d/:

[virtualbox]
name=Fedora $releasever - $basearch - VirtualBox
baseurl=http://download.virtualbox.org/virtualbox/rpm/fedora/$releasever/$basearch
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://www.virtualbox.org/download/oracle_vbox.asc

EDIT: verbose details with sudo dnf update -v:

Cannot download ‘http://download.virtualbox.org/virtualbox/rpm/fedora/28/x86_64’: Yum repo downloading error: Downloading error(s): repodata/8797acb2bdc4a098c1ebade2f11ff827324fddb42bd09973fef46490574f617f-primary.xml.gz - Cannot download, all mirrors were already tried without success.

But I can navigate and download that site/file from a browser.

EDIT2: The workaround of changing the baseurl in the repo file gets rid of the problem:

baseurl=https://download.virtualbox.org/virtualbox/rpm/fedora/26/$basearch

https://forums.virtualbox.org/viewtopic.php?f=7&t=89906


#1917

What is the best way to go about tweaking GPU settings? Like core clock, voltage, power limit?

I’m new to Linux and running Ubutnu 18.04. I have an AMD R9 290 so have to use the AMD proprietary drivers.

I am used to MSI Afterburner on Windows where it’s just some easy sliders and you’re set.


#1918

For AMD there is no easy tool like that which I am aware of. I was able to find this, which does it with the Open Source AMDGPU driver.
https://linuxconfig.org/overclock-your-radeon-gpu-with-amdgpu


#1919

Does anyone know of a reasonable way to open DRM protected Kindle textbooks in Linux? I’m on Ubuntu, and I need to open a textbook. Cloud reader doesn’t work. WINE doesn’t want to work. Calibre can’t open it obviously, because I can’t even download it.

Am I stuck trying to do this with a VM?


#1920

This was the first thing that came up when I searched.

https://linuxconfig.org/calibre-drm-removal-for-ebooks-on-linux

This is probably some sort of eula gray area.


#1921

I tried doing this in the past and I ended up doing it in a VM because all of the linux methods were so poorly documented.


#1922

That seems like the easiest solution, unfortunately. Not exactly an efficient solution. My poor 3570k is starting to show its age, I wonder if a Xeon would handle the VM better.

I guess I’ve paid for it, as long as I delete it after my rental is up…It is kind of a gray area, I guess. So annoying that piracy is often the easiest solution.


#1923

I wouldnt consider it piracy because you’re not stealing. You are, however, circumventing drm.