Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1884

Some windows programs “i won’t need anymore xD” the other is games from GOG, steam etc.

Today I switched to Linux Fedora because Windows decided to bluescreen.


#1885

Well, congrats on the switch!

Yeah, I’d just toss those mounts in /media.


#1886

On a related note to this, When I first installed Ubuntu 16.04, all my drives were mounted in /media, and were designated by the names I had given the drives. (exp: games, windows, media)

But since I’ve been on 18.04 The drives have all been mounted to /mnt/“uuid number.”

Is this a switch they did for Ubuntu or did I do something. The first way I describe was easy to know which drives were which. But now I’m having to keep a post-it-note to know which drives are what, cause some of the drive uuid’s are hella long.

Was this an Ubuntu change, or did I screw something up when I installed 18.04?


#1887

Did an sudo apt-get update
sudo apt-get upgrade

Seems to have borked my system
Is there a way to roll back? I haven’t set up a snapshot unfortunately

Ubuntu 18.04


#1888

I am getting the error kernel: ipmi:dmi: Invalid IPMI type: 0 on boot and in dmesg.

Running ubuntu 18.04 with kernel 4.18 on a supermicro x8dtl-i motherboard.

My motherboard does not have ipmi, but there are other x8dtl* boards that do. Is there a way to disable ipmi in the kernel?


#1889

set the default output to HDMI instead of DP?


#1890

Hello.
I am trying to get remote desktop access to my remotely Ubutu 18.04 machine.
I have I have a working Teamviewer and access via open ssh.
While I connect via X11rdp the session hangs, no error on the windows client side.
Any ideas ?


#1891

Do you have the x11rdp package installed on remote machine you are accessing?


#1892

My guess would be a misordered fstab. Typically you want to use the uuid to keep track of drives to mount them in the same location, but on a human readable mount point. You probably just used the uuid twice.


#1893

Short answer: yes.
Long answer: you really don’t want to roll back unless absolutely nothing boots properly.

Try looking in /var/log/syslog for starters, and see what went wrong. A little more detail can help us give you info for how to fix what broke.


#1894

Note that the following instructions are for a SysV system, and I’m not 100% that they work the same on your SystemD system:

grep initdefault etc/inittab
id:5:initdefault:

Find the number, that’ your run level. (Probably 5 or 3)
Assuming 5:

mv /etc/rc.d/rc5.d/K74ipmi /backuplocation

OR:

Go in to the following file and set these options to no:

vim /etc/sysconfig/ipmi
IPMI_SI=no
DEV_IPMI=no
IPMI_WATCHDOG=no

Let us know if you have issues. Good luck.


#1895

I didn’t do anything. This is how Ubuntu set them up. I haven’t touched fstab at all.


#1896

In that case, you could use the UUID to mount your drives to mountpoint called games, windows and media by adding a few lines to fstab (if they aren’t already in fstab). Let me know if you need help with this and I’ll provide a few examples.

I don’t use Ubuntu, but it’s possible that it parsed the drives and added them to fstab in the way it thought best, which means it could have changed for a number of reasons.


#1897

My problem is this. I built qemu from source with make install. But now there doesn’t seem to be a make uninstall function and I need to reinstall it because it’s behaving weirdly. How do I uninstall it completely.
sudo apt remove qemu*
hasn’t worked


#1898

sudo apt-get remove qemu* should work.


#1899

I tried that too and qemu-system-x86_64 --version still works. I think it’s because I built it from source on top of installing it from apt-get


#1900

apt isn’t going to uninstall it since you didn’t use the package manager to install it. Instead of using make install, make it into a .deb file then use apt for installation…then you can uninstall it with apt if needed.


#1901

huh. TIL.


#1902

That’s actually a good idea.
I’m trying it right now but running into permission issues.
I Will come back with the results as soon I get it working.


#1903