Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1844

:smiley: Any time.


#1845

I have an older 2560x1600 monitor that reports its native resolution as 1280x800. The display has no built-in scaler. Under X Windows, I can only get those two resolutions. I thought I’d try using xrandr to enable GPU display scaling, like so:

$ xrandr --output "DisplayPort-2" --set "scaling mode" "Full aspect"

However, this accomplishes nothing; I still only see 1280x800 and 2560x1600 as the available display resolutions.

Is there any way to get more resolutions under Linux? Windows has a full range of available screen sizes.


#1846

What GPU are you using and what DE are you using?
If you have nvidia, do you only see those two in this list in nvidia-settings?


#1847

Vega 56 with XFCE on Fedora 28.


#1848

Hey guys,

I am running a vserver and have a rather weird problem. The server has little over 700 GB hdd space and I just found out that a folder “/dev/ploop54996p1” is using 93% of the space. In numbers this folder is 713 576.15 MB out of 766 553.01 MB big. I have no clue what this folder is for.

The server is running Plesk on Ubuntu 14.04

Does someone know why it takes up all the space? What is this etc.? Can I delete it?

Thanks and kisses in advance :wink:


#1849

Why don’t you look inside to see if it’s got important data.

Not familiar with that naming convention, if you want to dump the tree, that would be nice.


#1850

Recommended best Kernel for gaming on AMD R9 290?


#1851

Well, it turns out that it were Plesk backups of a website that I run on the server. Backups for every day for half a year :smiley:


#1852

I’m trying to force Debian 9 to use eth0 for my ethernet NIC instead of the random device name it assigns. I added the following to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT=”net.ifnames=0 biosdevname=0 quiet“

and then ran “sudo grub-update”. That worked, but in a weirdly incomplete way. Now the ethernet interface won’t autostart at boot. However, if I run “/sbin/ifconfig eth0 up” after booting, the NIC comes up fine. I’ve also added the following to /etc/network/interfaces:

auto eth0
iface eth0 inet static
address 192.168.1.80
netmask 255.255.255.0
gateway 192.168.1.1

But that still doesn’t help. For now, I’ve added the necessary commands to /etc/rc.local, which is pretty kludge-y.


#1853

What happens if you add allow-hotplug eth0 to /etc/network/interfaces
Alternatively, try messing with systemd and try something like systemctl enable [email protected]


#1854

@SesameStreetThug Thanks, allow-hotplug eth0 worked perfectly. Though curiously NetworkManager is very upset about the whole eth0 thing and refuses to manage the connection. Not a biggie…


#1855

Are you using for a desktop or server? I typically avoid NetworkManager for servers.


#1856

I installed Debian in a desktop configuration, then “upgraded” it to a Proxmox (non-subscription) install. I didn’t consider that installing it in a desktop configuration would mess with the networking.


#1857

I’m pretty sure Debian doesn’t distinguish between Desktop and Server as it applies to networking. At work I typically use systemd-networkd (sue me systemd haters) and I don’t run into issues with it, there are other options too such as Wicked. At this point it shouldn’t matter as it seems you’ve gotten it working.


#1858

Just for the record, NetworkManager did cause me a bit more grief. /etc/resolv.conf was symlinked to some file in the /etc/NetworkManager directories, which prevented the server from finding anything not on the local subnet. I unlinked it and created a new resolv.conf from scratch.

That’s not the first issue I’ve had with NetworkManager. Seems to have its fingers in too many pies…

EDIT: Would it be a wise idea to remove NetworkManager (ie, apt-get remove network-manager)? I’m afraid an update might undo some of my changes. Is there any need to replace it with something else?


#1859

If you don’t want to use NetworkManager just disable it with systemD
systemctl disable NetworkManager
I would avoid removing the package, some other things may list it as a dependency.


#1860

I am using Ubuntu and an AMD R9 290

I am using the bundled open source AMD driver.

How can I see what version I am on and what/if there are any updates/newer versions


#1861

The driver is packed with the kernel. Theres no updates that YOU need to worry about. If theres a driver update, it cowes in as a kernel update.


#1862

I understand that it is bundled with the Kernel but I was wondering if there was an easy way to check what current driver I am on.

Another question I have is that my machine seems to slow down if left on for a number of days. A reboot fully sorts it out but it feels like that when I close programs that they don’t actually close.

Is this something Linux does? Is there a way to combat this?

Linux newbie BTW


#1863

So ever since i switched to debian, my monitor will not turn on when i attempt to wake it up.
The PC is not sleeping it just turns off the monitor after a set amount of time, but pressing anything or moving the mouse will not wake the monitor up.
When i turn the monitor off and back on it works fine again, googled a fair bit but was unable to find a solution.