Return to

The small linux problem thread



Nice. Seems to have mounted just fine with the uuid that blkid reported. Thanks

One more thing, my workstation supports hot plugging and works fine (formated and imaged the new drive this way). I assumed the server would but I cant find the drives unless I reboot. Its a supermicro board, is this not always supported?


might have to enable it in bios?


My post was largely tongue in cheek. Mostly :smiley:


UUID will make it mount properly if you plug it into a different port/bus or even a different machine.


I’m having trouble taking ownership of one of the hard drives in my computer. I saved it from when my computer was set up with windows, it has a two word name Local Disk (which I didn’t think to change while in windows) So trying to use chown to take ownership doesn’t work cause it’s taking Local and Disk as two separate arguments, and I can’t rename it for the same reason. any advice on how to get the name changed so i can actually start using my data?


Does \ not work

Local\ Disk

Otherwise you should just need to own the directory its mounted to.


unfortunately no, it’s the same directory, it’s not a directory called
" Disk" inside Local, it’s a directory called Local Disk.


\ is an escape character for using spaces in names


oh, my bad. I’m new to linux. and no it appears to not have worked
edit: nevermind i’m dumb and used / instead of “” it worked now.
edit2: it won’t let me put the slash cause apparently it’s used for some formatting on the forums but you get the idea.




OK new, problem. I’m the proud new owner of a read-only file system… tried changing permissions but apparently that didn’t work


Confirm that it was not mounted as read-only due to settings in fstab or a filesystem check failure.


nvm ignore this


I have a Ryzen 1600 OC’d to 3.75Ghz

I have boost disabled and have all C-States Disabled. However whenever I boot my CPU will sit at 1.3Ghz and I have to run “echo performance | tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor”

Any ideas why I need to run this after every reboot?


That is the expected behavior when you have low power mode support enabled in the BIOS. Without running that command the CPU will run at full speed if you run something intensive.
However the performance governor is still preferred for running games, which is why software such as Feral’s gamemode exists.


But I don’t have low power mode enabled - thats the thing


I’m trying to run a GPU miner on my AMD R9 290
It worked fine using Nicehash on Windows.

I’m now using Ubuntu and using the bundled open source driver for gaming and that works fine.

When I attempt to run the miner I get this error

[2018-10-06 23:17:10] Error UNKNOWN_ERROR when calling clGetPlatformIDs for number of platforms.

[2018-10-06 23:17:10] No OpenCL platform found.

[2018-10-06 23:17:10] AMD OpenCL platform NOT found.

[2018-10-06 23:17:10] Failed to start threads."

I am guessing that this is because I am using the OpenSource driver? Is there a way to solve this issue without downloading the driver from AMD?


Lets say someone back ups their system with tar (excluding /run , /proc , and other tmpfs mounts).

After using a live cd/dvd to restore the tar after recreating filesystems… whats the command to rebuilt the boot loader?



grub-install /dev/sdXY


thanks, I was having a brain fart