Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1784

You need to destroy and rebuild the container, to me knowledge. Docker is designed to be immutable.


#1785

My searching leads to the same answer as well. Though perhaps there’s a way to store the data (tests) separately?


#1786

You can mount a “volume” which is essentially bind mounting a directory on the host os into the container.


#1787

That’s what I had in mind. Remains to be seen if the pts docker image is amenable to such a setup.


#1788

It probably is, but you might be better off trying to get your tests merged upstream.


#1789

Been rocking a ASUS Radeon 7790 since new in 2013. Never had issues with the open source drivers. Around 2015 has been useful for playing real games. Went from Radeon OSS driver to AMDGPU driver. I think that there is something deeper that you may be doing to your systems that are causing issues.

I have run Debian unstable since 2003 and I run Arch Linux as my backup. Occasional issues on Arch, like when they finally upgraded the Libc packages but Debian unstable is pretty damn stable. And because it is Debian, minus a few bleeding edge packages, it is never as close to the edge as Arch. I prefer Debian over Ubuntu hands down. Ubuntu is based on the Debian Unstable and select packages from the experimental branch + Canonical’s philosophy on how configuration should be done.

If you want to take a stab at Debian running AMD. Let me know. You should have less issues with that RX580 than you are having. If it were Vega, I would understand.


#1790


Getting this error again keeps my desktop from booting to the login screen I don’t even have ecc ram so it doesn’t really make sense.

Wierd switching to fedora 4.17 gives the same error but boots past the login screen


#1791

If you have an ECC option in your BIOS/uEFI, disable it?


#1792

Don’t think I do. Tried looking in ASRock x99 extreme 4 bios, but couldn’t find anything related to ecc, only ram overclocking


#1793

I don’t think that is an error. More of a warning.

For your Fedora install, are the graphics drivers and other drivers different from the install on which you couldn’t get to the login screen?


#1794

Not sure the boot options let’s me choose between fedora 4.18 and fedora 4.17. I think it might have been a bad update for the 4.18


#1795

So. scenario.

Kubuntu 18.04
Ryzen 2700X on Asrock Taichi X470
2x Vega 64 reference
Audio intended to come out of HDMI on primary vega card.

Sometimes works
sometimes doesn’t
some apps decide they will output properly
some apps don’t
no rhyme or reason.

totally craptastic mixer looks like this:

Screenshot_20180922_005247

i mean… really? this is helpful… not

settings as pictured, no audio from GOG Planescape Torment. yet Mozilla works. Some/most steam games work.

my audio was more reliable under linux in 1996.


#1796

I haven’t tried this myself but perhaps you could unbind snd_hda_intel from the secondary video card’s audio subdevice. This might help:

https://ubuntuforums.org/showthread.php?t=2183937

I know he didn’t succeed, but the same process should work in theory.


#1797

Have known some KDE users have problem with Plasma settings not functioning right or not saving settings

suggest:

  1. Delete home folder Pulseaudio cookie rm ~/.config/pulse/cookie
    then restart pc to creat a fresh one

  2. Install pavucontrol-qt to adjust Pulseaudio settings
    (this will save changes that may not have been saved right in plasma settings)
    and try changing profile for unused HDMI to ‘Off’ in Configuration tab


#1798

From Netdata installation:

 --- Check KSM (kernel memory deduper) --- 

Memory de-duplication instructions

You have kernel memory de-duper (called Kernel Same-page Merging,
or KSM) available, but it is not currently enabled.

To enable it run:

    echo 1 >/sys/kernel/mm/ksm/run
    echo 1000 >/sys/kernel/mm/ksm/sleep_millisecs

If you enable it, you will save 40-60% of netdata memory.

Any reason not to do this? If not, why isn’t it enabled by default?


#1799

It can reduce performance a bit.

If you’re running out of ram, enable it.


#1800

Anyone use this? Looks nice, but I wonder if it would get in the way sometimes.


#1801

Yes. I use it on all my desktops. Not worth it for servers.

Works well, makes it A E S T H E T I C A S F U C C and that’s all that matters.


#1802

I use it - like it.

Don’t think it has been in my way once.


#1803

More importantly, don’t use bash. Bash is for noobs…

(oh my) zsh master race.