Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1643

#1644

A clue:
https://solus-project.com/forums/viewtopic.php?t=2630

Appears to be related to udisks2 defaulting to /run/media


#1645

Yeah it’s a Gnome thing. I never noticed it before.


#1646

I don’t see why it would. The default location for a machine in virtual box is located in the home folder of the user that creates it.

Unless these are VM’s you want other users to access.


#1647

The link I posted says Ubuntu patched it so everything mounts to /media like normal. I wonder what all’s involved with that. I mean, it’s not really hurting anything. But it does seem to go against convention or spec.

Nope, no one else needs access. I’ll probably just mount the drives in my home directory.


#1648

Anyone know of a good, fast USB WiFi adapter for Linux? Preferably one that is plug-and-play, but not necessary.

I ask because my Panda adapter recently bugged out so I bought a Netgear one and it works great… in Windows. I’m seeing about 40mbps download speed increase.

Used to have:

Now have:

The Panda one was plug-and-play, which was really nice, but I don’t really want to buy another one when I’m getting much better performance (in Windows) out of one that’s not much more expensive. For Linux I’m sharing the WiFi connection over ethernet from my laptop, but it’s pretty old and it’s slooow in comparison.

The problem is Solus doesn’t seem to play nice with Netgear (https://dev.solus-project.com/T5657), so I’m looking at getting a different adapter. I don’t really want to switch distros mostly because Solus is the easiest to set up with my hardware, and a few other reasons.


#1649

So, an update to the VM image transfer to SSD project, in case anyone wants to do that but doesn’t know how (probably not very many people).

Original problem and goal: move VM image (.img file in my case, would work with qcow too) to an SSD, but image was larger than the SSD.

Quick high level overview of the process:

  1. Copy original VM image to a new location, don’t do any of this on the original file.

  2. Boot copied VM image file. Clean up junk files, uninstall unneeded games and software, defragment. Shrink NTFS partition as much as you can from within Windows using Disk Management. Will probably have to reboot several times to move “unmovable” files.

  3. Shut down VM and follow instructions at this link: the link

  4. dd the new image file to SSD

  5. Add the SSD to your VM via this link: the other link

  6. ???

  7. Profit

I am now booting my VM off of the SSD. It is very nice.


#1650

A somewhat annoying problem

I want to get my line-in audio port to be a loopback device - as in playback audio from it directly to my headpones and I also want my mic in port to remain independent and not be part of the loopback device.

Here’s the problem, pulseuaudio works with sources and sinks and for some magic reason, all the input ports are part of a one source.

pactl list sinks short

0       combined        module-combine-sink.c   s32le 2ch 48000Hz       RUNNING
1       alsa_output.pci-0000_29_00.3.analog-stereo      module-alsa-card.c      s32le 2ch 48000Hz       RUNNING

pactl list sources

Source #3
        State: SUSPENDED
        Name: alsa_input.pci-0000_29_00.3.analog-stereo
        Description: Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s32le 2ch 48000Hz
        Channel Map: front-left,front-right
        Owner Module: 10
        Mute: no
        Volume: front-left: 15073 /  23% / -38.30 dB,   front-right: 15073 /  23% / -38.30 dB
                balance 0.00
        Base Volume: 6554 /  10% / -60.00 dB
        Monitor of Sink: n/a
        Latency: 0 usec, configured 0 usec
        Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
        Properties:
                alsa.resolution_bits = "32"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC1220 Analog"
                alsa.id = "ALC1220 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "2"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfe600000 irq 58"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:29:00.3"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:29:00.3/sound/card2"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "1457"
                device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
                device.string = "front:2"
                device.buffering.buffer_size = "768000"
                device.buffering.fragment_size = "384000"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo"
                alsa.mixer_name = "Realtek ALC1220"
                alsa.components = "HDA:10ec1220,18491221,00100003"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                analog-input-front-mic: Front Microphone (priority: 8500, not available)
                analog-input-rear-mic: Rear Microphone (priority: 8200, available)
                analog-input-linein: Line In (priority: 8100, available)
        Active Port: analog-input-rear-mic
        Formats:
                pcm

I want to do this

pactl load-module module-loopback latency_msec=1 source=3 sink=1

Essentially send input from source 3 port 3 (line in) directly to line-out, except It only accepts an entire source with multiple ports, I want to just loopback the line-in port…

Are channels here perhaps referring to ports?

Does anyone know how to do this with pulseaudio, is it even possible? Or do I need to create a virtual sink from the line in source port and mix it with sink 1?


#1651

All in all this seems like Pulseaudio Programmer idiocy.
Nobody asked for this extra headache just to shuffle around input sources.

I’m guessing a possible way to do this may be to module-remap-source and split the source out into multiple sources based on it’s ports?

Maybe that’s also not possible since I only have a limited amount of AD’s

02-00: ALC1220 Analog : ALC1220 Analog : playback 1 : capture 1
02-01: ALC1220 Digital : ALC1220 Digital : playback 1
02-02: ALC1220 Alt Analog : ALC1220 Alt Analog : capture 1

So mixing anyone?


#1652

It’s a lost cause. Mixing in pulseaudio is idiotic.
Use alsa directly or install jack and get it done with.


#1653

I’m having to run the following command in terminal after every reboot - Is it possible to get it to run automatically?


sudo -i

echo performance | tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor


#1654

you could put that line into your /etc/rc.d/rc.local file… I believe this does not work on systems with systemd, as systemd is different.

Their is a program out there called cpupower and you can use that program and systemctl to do what you want to do.


#1655

I’m trying to hook up an Apple Wireless Keyboard (model A1314) to my Fedora 28 Cinnamon Spin laptop. It connects, but all I can get out of it is numbers, as if I had added a bluetooth number pad. I’ve tried changing the keyboard layout to English (Macintosh) but, again, all I see are numbers (and the / and * characters.) It works OK in Windows, so I know the keyboard itself is functioning properly. Any suggestions?

EDIT: Solving this was so simple. I just turned off the numlock on my wired keyboard and the Apple keyboard started functioning properly. pfft.


#1656

EXCUSE ME

Ahem

Has anyone compiled Vim from source on Debian Stretch? I can do it on Ubuntu, Fedora, and Arch without issue. On Debian, after compiling, when I type vim I get an error that it doesn’t exist.

Using this guide:

I’ve even tried which vim before removing it, and using that path as the installation location when running configure

No idea why I’m such a failure :frowning:


#1657

You may have to run it using it’s complete path depending on where you installed it.


#1658

That’s the thing, I’m pretty sure I installed it in /usr/local/share/vim

I’ll make a VM and perform a snapshop before compiling and see if I can figure it out.

Will revisit the path, though. Great idea! Thanks.


#1659

Its time to reinstall the OS On my desktop. It has been through every ubuntu upgrade since the 14.04 days, and its finally saying that it does not want to live anymore.

Which is too bad, because its going to live whether it likes it or not.

My problem: I have a large ZFS pool that hosts my home directory that I would like to keep around. If I reinstall the OS (I will likely switch to Fedora), does that mean I lose the ZFS pool?


#1660

As far as I know, when you start your install from the live usb you should get an option on the bottom where is says formatting and stuff? I think the first option is to install Ubuntu along side other installations?

Go down to the last one that says: (I think)

something else

And it will give you a choice to partition hard drives. When you have to repartition your home directory, choose change, then select format type, e.g.: ext4, then select where to mount. Tell it NOT to format it, and assign it to /home. You should retain all your home files. I think I’m right in this.

(I’ve installed Ubuntu way more times than I should have due to corrupt installs.)

Please anyone correct me if I’m wrong.

*Edited to reflect actual steps


#1661

I’m on Debian Sid. Compiling it rn, but, just informing, here the binary for vim was located at /usr/bin/vim (output of which vim) but the $VIMRUNTIME was set to /usr/share/vim/vim81, so I guess it just isn’t the right directory to put into the prefix (maybe it is not in the $PATH.)


#1662

Well, that’s done. I ran configure with --prefix=/home/user/.local, and after running make (and then the make install) as per the guide my ~/.local/bin was promptly populated with vim binaries. If your installation finished without errors, I recommend dry-running make (sudo make -n install) to see where the heck are those binaries going. Also, check the $PATH.

In the first ~12 lines there must be a line like cp vim [your prefix]/bin, that must be where it is going to go when you run it for real.

Also, why is vim so damn bloated??