Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1623

Installed over an old Ubuntu 14.04lts to 18.04lts with luks and was laggu, then debian w/o luks- still slower and laggy. Is it the meltdown and Spectre fixes? Currently at 4.17.0.

Makes me want to go back to an older kernel

Added nopti nospectre_v2 nospec to grub, soooooo much better.


#1624

Is it at all possible to take a VM that’s in a raw img file and move it to a physical SSD so it looks like an actual install of Windows?


#1625

DD command


#1626

That’s what I figured. I’ll try it in a while.


#1627


Getting this error


#1628

But this message goes away and you still successfully boot though, right?


#1629

Not having any luck transferring the image to the SSD.

I tired it with both the original image, which is quite a bit larger than the SSD, as well as a shrunk down version where I did qemu-img resize windows10pro.img 475G

I tried going through Disks, and doing a “Restore Disk Image” on the SSD, but that both took a very long time, as well as didn’t work.

The dd command I am using is this:
sudo dd if=/run/media/marasm/BulkStorage03/windows10pro.img of=/dev/sda bs=4M conv=noerror,sync status=progress

Everything I do I end up with a blank disk:

Not sure what I’m doing wrong.

EDIT: So, apparently the SSD is actually bootable. I did it on bare metal as well as added it to the VM and booted to it. Still shows as being empty in Fedora, not sure why.

It takes a very long time to boot, though. Several minutes of spinning dots, then some kind of reboot and blank screen, then the login screen. Something isn’t right with it.


#1630

nope can’t even get into login screen


#1631

Oh, I’ve gotten an error like that before, but it would still boot…and I’ve only seen it while I was trying out Arch.


#1632

How/Why would your win10 install be under the /run directory?


#1633

That’s where I have the 8TB internal hard drive mounted to. And a couple 1TB drives are mounted like that too. Maybe I’m doing that wrong? Been working fine for a while.


#1634

I don’t think this is causing your current problem, but mounting drives in /run Is very weird.

Here is the official spec on what goes where:

http://refspecs.linuxfoundation.org/fhs.shtml


#1635

Yeah, somewhere along the line my brain decided it was OK to mount my drives there. That’s the default location Fedora mounts external hard drives, so… I just went with it. I’ll mount the internal drives to mnt from now on.

Not sure what’s going on with the imaged SSD, though. I remember shrinking img files for VMs before, and I think I recall having to do something else besides qemu-img resize. The file system may be corrupted. Just imaging the image to the SSD may not be enough, need to fix the mbr or boot partition or something?


#1636

Really? I wonder what specifically is mounting it there and why…


#1637

If these are storage drives that you want owned by your user, you should mount them in your home directory.


#1638

Dunno. I just installed my desktop fresh (which, coincidentally, is why I am rebuilding my VM setup), and I just tried plugging in a couple external drives and they mounted in the same place as previous. /run/media/…

Interesting. May look into it. Would that cause issues if I store VM images there?


#1639

Which DE and what filesystem on the drives?


#1640

Gnome, ntfs


#1641

That really seems wrong to me, but I’m sure there’s some rational explanation. Wish I knew why. My guess is that Gnome is doing it but I could be wrong.

Oh, NTFS. Maybe it’s a fuse thing. @sgtawesomesauce do you know why it’s mounting under /run?


#1642

Does it with USB flash drives too. Reformatted it to ext4 and it still mounted there.