Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1461

Uh oh. At least you still have half.


#1462

Sorry to hear that. My Realtek NIC died on my 990FX back in Feb. I just now am accepting that I need an add in card for this Bulldozer build. Currently using a USB wifi stick.

I need RAM to go down in price so that I can build a Ryzen setup.


#1463

Just a note for anyone searching… And ill probably explain this wrong but my problem is fixed…

After updating the kernel to an unofficial version virtualbox will break. Installing Virtualbox from the ubuntu repo still uses virtualbox-dkms. Dpkg-reconfigure virtualbox-dkms and modprobe vboxdrv are useless.

Installing virtualbox from the virtualbox.org using the deb will update you to a version that is independent of the kernel modules fixing the problem. I’m currently on 5.2.16. Ubuntus version was 5.2.10-dfsg-6ubuntu18.04.1


#1464

You may have been able to dkms install rather than dpkg-reconfigure and it would have probably worked.


#1465

While im not going to break the golden rule and mess with something that works. Ill start a vm and try it out just to verify.

Break a vm, within a vm, lawl

actually, can i run virtualbox, within virtualbox?

If the forum turns inside out, you’ll know something went wrong.


#1466

Nope, and this is as far as I take it.

sudo dkms install virtualbox/5.2.10

Creating symlink /var/lib/dkms/virtualbox/5.2.10/source ->
                 /usr/src/virtualbox-5.2.10

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j8 KERNELRELEASE=4.17.9-041709-generic -C /lib/modules/4.17.9-041709-generic/build M=/var/lib/dkms/virtualbox/5.2.10/build.....(bad     exit status: 2)
ERROR (dkms apport): kernel package linux-headers-4.17.9-041709-generic is not supported
Error! Bad return status for module build on kernel: 4.17.9-041709-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.10/build/make.log for more information.

#1467

iirc it only works when you hide the fact that its a VM


#1468

Seemed to work fine. Didn’t do anything special. The parent VM had amd-v enabled not sure if that matters.
But I wasn’t checking functionality, more interested in making it fail the same way mine did.


#1469

I have this really frustrating thing now for a while…
Ubuntu 18.04 currently running, but had it before…

Ubuntu things that my monitor is a 27 inch 4K display, while in fact it is a 32 inch 4k, that’s the first thing that’s odd.
this doesn’t really bother me, but on a 100% scaling everything is tiny, the only other option Ubuntu gives me is 200% witch will be suitable for my 90 year old granddad…

so… how do I get this on the right scale?

also, in Windows I run 150% scaling what would be absolute great if this scale would be possible on ubuntu.


#1470

Really basic question here. In the past, if I wanted to run a command at boot, I would’ve dropped it in rc.local. But that has apparently gone bye-bye.

If I want to run a command (not a service/daemon!) at system startup, where do I put it in Fedora 28?


#1471

What WM/DE are you running?
Are you using Wayland or xorg?


#1472

rc.local should still work. I have not touched fedora in ages but rc.local works on debian SID ans Arch for me.

Most DEs allow you to run scripts and programa on startup as well.


#1473

I put the following in /etc/rc.local:

#!/bin/bash
/usr/bin/cpupower frequency-set --governor performance
/sbin/ifconfig >> /root/netconfig.txt

And there’s nothing in /root and CPU clock speed is still ~800MHz.


#1474

I am running xorg.
sorry i’m a bit of a Linux noob.

I’ m just running Ubuntu 18.04 default. Currently a fresh install.


#1475

I have an ASUS Crosshair VI Hero with an 1800x, After building this system I went back to using Windows :sob: After watching Wendel on Linus Tech Tips a couple days ago I decided to play around with Ubuntu again. Ubuntu 18.04 does not have an option to Hibernate and when it puts my computer to sleep it will not wake from keyboard or mouse. I also ran into this on Windows but when using Hibernate and the Asmedia 3.1 USB ports it will wake up from Hibernation.
Any Advice?


#1476

Quick piece of mind question. I’m running an Ubuntu system with a Windows VM and a passed through GPU. The sound from the VM is quite scratchy and distorted.

I have it set up so it is almost perfect, but I wanted to throw an idea out there to maybe fix it. I was thinking about getting the cheapest sound card I could, passing it through, and then running a male/male 3.5mm cable out the headphone jack of the sound car into the line in on the motherboard for Ubuntu. Then allow that line in to be heard through the motherboard headphone out jack within Ubuntu. Basically letting you listen to the line in.


#1477

I usually put it in cron


#1478

I guess that’s one way to approach it. Still curious why rc.local isn’t working. Has it been deprecated in favor of systemd? It seems silly to create a service for a one-liner at boot.


#1479

Startup apps in Gnome 3

https://samurailink3.com/blog/2016/01/04/startup-apps-in-gnome-3/


#1480

Thanks for the suggestion, but there are two problems with that. For one, I’m using the Cinammon spin. For another I’d like to apply it at boot in case I don’t login immediately, or someone else logs in.

But I seem to have found a better solution. By disabling C-States and SpeedStep in the BIOS, I can force the CPU to run full tilt at all times.