Return to

The small linux problem thread



So, this is something that I have struggled to wrap my brain around for years now. I just can’t get the hang of networking my VMs properly.

I just spent the last hour and a half trying to follow this guide: I was informed as I pasted that link that I already posted this link in October of last year. Yeah.

But it just won’t work. I can’t create a bridge. I have no Idea what I am doing wrong. At this point everything is back to stock.

So. Here is what I have:

Some VMs:

Some network interfaces:

The network interface ‘enp4s0’ is considered the primary, and is assigned a static IP address from my pfSense box. This is my file and plex server, so it is important that this IP stays the same.

The network interface ‘enp34s0’ is the add-in NIC, and is currently DHCP. I want to use this to share to my VMs. If there is a way to do it with the primary while keeping the primary’s IP, then that’d be cool too.

The important bit is each VM needs its own IP address, statically assigned by my pfSense box. Each VM gets a randomly generated MAC address, and I have assigned IPs to VMs before, so I know it works.

Right now, since I did a fresh install of my file server, none of this is working. I don’t remember what I did with the old install, and this time I’m writing shit down. Also, the second NIC borks VNC for some reason. That sucks, but I can still SSH in.

If someone would be so kind, I’d greatly appreciate some knowledge on the subject.

I found this spectacular guide that does exactly what I want:

It doesn’t quite work, though. I can assign the VM to use the host-bridge network, but when I hit the play button it switches to specify shared device and the VM doesn’t get an IP address. So close.



Does anyone here have any experience with using qemu user mode? The only guide I found so far is for debian but I am currently using Arch Linux on my device.

My goal is to run x86 applications on my Arm64 device (Nintendo Switch). Does anyone know if there is a good guide out there to set this up?



Is anyone else on Fedora (MATE) not getting the dnfdragora notification icon in the taskbar when updates are available?

I usually get the icon once, but after closing/quitting, it doesn’t come back later when more updates are available.


After doing some research, I understand (to some extent) how one would set up an x86 chroot environment on an arm device.

Basically, you need to use both binfmt_misc and a qemu-static build. A Linux Arm device wouldn’t normally know how to handle x86 binaries, but binfmt_misc tells the kernel what program it should use when you execute the x86 binary file.

Now I am running into another problem. On Arch Linux Arm, I am unable to compile a static build of qemu, yet, I am able to compile a normal version of qemu just fine.

I always run into this error when I try to run ./configure --static:

ERROR: sizeof(size_t) doesn't match GLIB_SIZEOF_SIZE_T.
       You probably need to set PKG_CONFIG_LIBDIR
       to point to the right pkg-config files for your
       build target

looking at the config.log, it seems that the linker is having trouble finding the packages (It seems to work fine if I remove the --static argument).

Here is the entire log if you want to take a look at it.

So my question is… why does the linker complain when I use --static, but works fine when I remove that argument?


Is anybody else having issues with post 4.17.7 kernels and the radeon driver not working? Even gone as far as to compile 4.18-rc6 but no luck. Need gpu support as linux is my primary gaming platform

will post 4.18-rc6 sysinfo later

tagging @sgtawesomesauce because im stuck between a rock and a hard place here


I’m using Nvidia or Intel on Linux. I could switch over tomorrow if you’d like me to test it, my amd gpu is vfio’d.

So, what specifically is going on with it? Is there poor performance, are you getting black screen, is the driver not binding?

Also, are you talking about radeon or amdgpu?


doesnt load on bootup. loads video in place. running modprobe radeon causes a black screen with the little blinking cursor at the top right.

radeon. Sadly amdgpu isnt supported on my card. firepro m5950 incase it matters (terrascale 2)


Ah, okay. I really have very little experience with radeon, since I was Nvidia only until the r9 3xx series.

Are there any messages in dmesg when you modprobe? It seems like theres something going on.

Do you have your xorg radeon drivers installed?

Is this new with a new kernel? You might actually consider using an older kernel for radeon, since it’s no longer the focus.


no way of checking without video XD

Yes. Both with a vanilla kernel (compiled myself) and the stock fedora 28 kernel

Newest kernel that works so far is 4.17.6-200.

That might work now but will be a bitch todo later on when something like fedora is past 4.17.6 as the default.


Yeah, I know. I’m not sure what sort of regression happened, but if you open up a bug, they might be able to fix it for future releases. The problem is that it’s hard to have them fix it without pinpointing the problem.

Okay, so this is a fairly new regression. :thinking:

And the vanilla kernel gives you the same results?

Right, forgot you don’t have another system you can use. :frowning:

Another way would be to configure systemd to save the journal across boots.

Do that, then run your modprobe and reboot (hard reset if necessary) it after a bit then you can load it up with journalctl -b1


Yeah. kernel stuff beyond configuring and compiling is beyond me so i dont even know what to start poking first.

Thankfully yes. cant find much in the change logs so i might start having to hack the older radeon source code into the newer kernel and doing stuff like that. Takes alot of computation time and regular time todo that kind of stuff though sadly.

yep. Newest ive gone is 4.18-rc6 though i might try upto the latest master branch on github to see if that helps.

Thanks. Will look into it.

Thanks for the help though. Kernel stuff is very much beyond my knowledge so i dont know how much i dont know XD


Won’t help. If there was a fix, it would have been backported into Fedora by now. Fedora really is the first stable distros to get fixes backported, thanks to redhat.

I’m thinking this is a configuration error. Post your xorg.conf? (you are running on xorg, not wayland, right?)

You won’t grow out of this, trust me. You’ll know more, but that doesn’t mean you can see the edges of the playing field.

As much as it’s important to stay up to date, it might be time to accept that freezing 4.17.6 might be the solution until Fedora can sort out their issue, if there is one.

I’m fairly convinced it’s a configuration issue somewhere.

Alright, I’ve got a busy day tomorrow, so I’m gonna get some shut-eye. I’ll loop back with you tomorrow.


worth a shot. Better than letting all this CPU horsepower goto waste

Do people still use xorg.conf? XD
Always let xorg just do its thing on its own as it does it quiet well. only thing i really have is a keyboard conf file that tells it to use the US layout but that was put there by fedora

Im on the level where the idea of edges on the playing field sounds like a rant of a mad man.

its not a kernel config option. is almost no difference besides something for a crypto module

Ive already accepted and living with it. Now its time to figure out a solution to improve my situation. Only other fix for this atm would be to upgrade my laptop gpu from amd firepro to nvidia quadro but that has its own issues that might not even be worth the hassle.

Alright. Im gonna continue poking at it with a stick


@sgtawesomesauce thanks for taking the time to help me. Did a clean fedora install onto my sd card and the latest kernel loaded up the radeon driver no problem. Time to reinstall i guess :frowning:


Glad to see it’s working better.


You and me both. Means i can actually use my laptop with newer kernels :smiley:


So, still struggling getting my VMs LAN access. I followed this guide to the letter, and it almost completely works.

I removed the second NIC, and created the bridge attached to my main NIC, using the slave interface per the guide. Everything appears to have worked fine, and I can access my file server using it’s normal IP address. However, when I tell the VM to use the bridge (host-bridge, second half of the guide where you have to define the network using virsh) the VM doesn’t use it. It switches to something else as soon as I start the VM.

Any suggestions?


I know that I am late, but are you using the latest non_free firmware package? Where there is a major upgrade to Mesa or the AMD drivers, they sometimes rely on the newest firmware to load at boot as well. I use Arch and Debian so I am not too much help here.

I have been running the full and proper open source AMD stack since 2012


Think i managed to find what caused it even though i dont like what it was. Probably a bad stick of ram considering one of my memory modules just died