Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1421

Found it, its called alacarte.


#1422

alight, so i tried doing

sudo dpkg -i nvidia-dkms-390
dpkg: error: cannot access archive ‘nvidia-dkms-390’: No such file or directory

which gave me the error up above… However, i figured out a temp solution to boot into Ubuntu with nvidia gfx working,

if i boot into recovery and tell the system to reboot normal everything loads fine and nvidia loads the display driver. I also don’t see the error that i posted above.

Still strange that I can’t boot normal. anyone got ideas?

thanks,


#1423

Oh, damn. I used to have this problem on Ubuntu based systems. I forget how I fixed it though.


#1424

what can i do to help you remember!! this has been a hassle since i got the 1060, my 760 had no issues booting.


#1425

Let me eat dinner then go back through my notes.


#1426

appreciate it. having a work around is nice, but id like to be able to just push power and let it load.

unfortunately, i gotta hit the sack for work in the AM, thanks again SGT, hopefully you can provide me with some good new =D


#1427

I’m having a Plex problem. I don’t know if it’s a permissions issue, or a version mismatch issue. Anyone here know much about Plex?

I just tonight reinstalled my file server from scratch. Set up ZFS and imported the pool. Installed Plex. The way I backed up the old Plex data (cache, metadata, database) was copy the directory (/var/lib/plexmediaserver/…) to a flash drive and paste it in the same place on the fresh system. Only problem (possibly?) is the version I installed is almost certainly newer than what was running on the old install. Would this be an issue?

The permissions I have set up thus:

The two pertinent directories:

drwxr-xr-x. 16 admin admin 16 Jan  7  2017 movies
drwxr-xr-x. 64 admin admin 65 Jun  6 22:34 tv_shows

And some sample file permissions, everything is like this:

-rwxr-xr-x. 1 admin admin  577427832 Jun  6 07:15 ''
-rwxr-xr-x. 1 admin admin 2347088694 Jun  6 07:02 ''
-rwxr-xr-x. 1 admin admin 2346846478 Jun  6 06:57 ''
-rwxr-xr-x. 1 admin admin 2346820010 Jun  6 07:13 ''
-rwxr-xr-x. 1 admin admin 2347275178 Jun  6 07:14 ''

And groups are thus:

admin : admin wheel plex
plex : plex video admin

Nothing will play, and when I scan it seems like it sees the directories, but not the files.

What am I missing?


#1428

Possibly. I would try setting up plex from scratch and importing a test library to see if it still works


#1429

Yeah, I just deleted everything in that folder and set up the library from scratch. It is now discovering everything and it can play video.

Now I just need to figure out how to merge stuff from the old library, like what’s been played and edits to titles and stuff. I know I did this exact thing a year or so ago, but I can’t remember how I did it or what I did.


#1430

probably just need to install the same version as the old install and do a normal upgrade


#1431

I had this problem once before so I now have Plex running in its own VM and share the library to it via NFS. This way I can quickly move the install between machines without down time.


#1432

Sorry about that. You would need to be in /var/cache/apt/archives/ and add .deb to the command. Dpkg -i is install a package.

Probably it would be easier to do sudo dpkg-reconfigure nvdia-dkms-390


#1433

Well, that’s the sticking point I guess. I don’t know what version I’m coming from. When I was backing up the old system I remember seeing the Plex package in Downloads, but of course I didn’t grab it. I guess it’s not such a huge issue. I know what I’ve watched and edited, just work I was hoping to avoid.

That’s a great idea. I already have VMs for torrent and clonedeploy. I could create one that uses quite a bit more of the system resources so Plex runs smooth. Would definitely make this process smoother in the future.


#1434

I run Plex on a Arch headless VM and only allocate it 1GB of RAM. The amount of RAM you dedicate it depends on the resolution of the media you are transcoding and the amount of simultaneous transcodes you plan on supporting.

Probably a good idea to do some testing to see how much you actually need.


#1435

Yeah from my experience, with how I use Plex, core count and speed are important. I was running it on a ultra low power, low clock, dual core / four thread Xeon for a bit, and playback buffering was terrible. Running on a regular low power, quad core / eight thread Xeon with much higher clocks is perfect.

I’ll probably spin up a VM tonight and do some experimenting. Maybe give it four cores and 2GB to start and see what happens.

Thanks for the suggestion.


#1436

Any idea on how to solve my problem over there?

I’m posting this here since no one responded thus far :disappointed_relieved:


#1437

A small issue that I’ve been having that isn’t a big deal, just a little annoying is that the Nvidia X Server application doesn’t remember my multi monitor positions. I tried the Save to X Configuration File, but it doesn’t seem to do anything, still every reboot it is reset. Any ideas?


#1438

I looked at your issue, but wasn’t able to come up with a potential solution. Let me have another look.

My recommendation for the future is to find a wireless NIC that has good Linux support out of the box.


#1439

well i tried it, no luck. even purged the drivers and installed 396 with no luck.

i have however stumbled accross something… i removed quiet splash from grub and got ubuntu to boot basically in verbose mode so i can see what its doing.

system hangs everytime on [OK] Reached target Sound Card

im not sure as to what sound card that would be, im going to assume its the NVIDIA from HDMI as the system boots fine without nvidia drivers being installed.


#1440

@sgtawesomesauce & @TheCakeIsNaOH

i decided to run through my bios and changed somethings around, mainly turned off integrated GFX and enabled fast boot, actually, that might be all i did…

anyways, system booted up 100% with zero errors and nvidia GFX working in heaven benchmark.

thank you both for your assistance,