Return to Level1Techs.com

The small linux problem thread

linux
helpdesk

#1401

Hey Guys!

Sooo… I’m kinda stuck between a rock and a hard place.

How does one find out whether a program is compiled with which options after it is compiled and running /usr/bin/ ?

I’m looking into using gcc with some weird options to look into that but haven’t found stuff yet. Anyone any kind of idea?


#1402

Very basic suggestion, but if you compiled it from the CLI, maybe check .bash_history?


#1403

I haven’t compiled it… sadly… otherwise i would do that.

like in every office “no one has compiled it” “no one knows who did it” … yadda yadda yadda…

and for security reasons & hr reasons i cant get into their accounts and check…


#1404

so I totally didn’t do that and it absolutely didn’t help me so I would never ever do it and so should nobody else.


#1405

How can I find out why the nvidia driver isn’t loading? The system has fallen back to the nouveau drivers.

This happened after the first time the nvidia driver was updated with dnf. There were no problems with the driver loading after kernel updates many times before.

I’m using the negativo repo on Fedora 28.

EDIT: Looks like the problem was with dkms failing to build for the 396.45 module. It stopped with an error when it couldn’t find files related to the older 396.24 driver which presumably got removed on the update:

$ sudo dkms autoinstall
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/396.24/source/dkms.conf does not exist.

For now I deleted /var/lib/dkms/nvidia/396.24 as well as some older kernel-* directories which linked to the older 396.24 directory.

But now how do I prevent the same problem on the next nvidia driver update?


#1406

I´m still facing update issues with Ubuntu Mate 18.04.
So far it has not really been a smooth experiance with the Bionic Beaver.

Still concidering jumping to something else.


#1407

When it updated from 17.10 to 18.04, my mate install broke a bit. The brisk menu seems a bit wonky.

Not badly broken, just some bits left out.

I think I should have done a clean install, but failed to summon the effort


#1408

Hello,
you might be able to help me and i’d appreciate it very much since i’m stuck.

i’m running into wierd stuttering, freezing, blackscreen and no displayOutput issues with my RX Vega on all relevant kernels.

Installed is Manjaro 17.1.11 and XFCE 4.12.2, suposedly amdgpu and every Kernel upwoard of and including 4.15.

Let me first describe the issues before i dig into when i have those.

Stuttering / freezing: All windows freeze for a short moment.
Audio keeps on playing correctly. Mousecurser is still movable and is not affected. Moving around windows is the most visual way of detectiong those stutters, they stop moving duringthe freeze and then move to where your curser moved them to, or droped them off.

Blackscreen: The screen stays black even though the display gets an input signal.

No signal: Monitor goes to standby.

Now to the kernels i have those issues with.
All installed by the manjaro kernel utility.

Kernel 4.18rc5.0716.g … experimental: gives me no signal after the DM takes over. “ok, its an experimental, i guess that’s ok”
Turning the monitor of and on again jields a input-signal with a permanent blackscreen.

Kernel 4.17.7-1 does regularly give me no signal after the DM takes over, though it recovers once the monitor “hotplugs” itself after going to sleep.
I then either have the stutters and freezes, reolution problems with my monitor stuck to HD , or very rarely no problems at all.

Kernel 4.16.18_rt10-1 is similiar to 4.17, though it has the problems a bit less frequent.

Kernel 4.15.18-3 gives me the least problems.
Though the freezes appear here too from time to time. No Blackscreen or noSignal issues here, except when cycling off and on the Monitor to try to get rid of the freezes.
That sometimes works, sometimes only a reboot gets rid of those freezes.

Dmesg is logging the following suspicious messages

Summary

[drm:generic_reg_wait [amdgpu]] ERROR REG_WAIT timeout 10us * 3500 tries - dce_mi_free_dmif line:563
WARNING: CPU: 10 PID: 917 at drivers/gpu/drm/amd/amdgpu/…/display/dc/dc_helper.c:195 generic_reg_wait+0xe7/0x160 [amdgpu]
Modules linked in: fuse ib_isert iscsi_target_mod ib_srpt … many more. Call Traces etc.

[drm:dm_vblank_get_counter [amdgpu]] ERROR dc_stream_state is NULL for crtc ‘1’!
[drm:dm_crtc_get_scanoutpos [amdgpu]] ERROR dc_stream_state is NULL for crtc ‘1’!

Besides the kernels, i have tried a few more things.
Installed different drivers, MHWDs video-linux which seems to include amdgpu which i thought is the correct one.

Manually installed xf86-video-amdgpu.
Tried the experimental version.

Tried no driver at all, assuming that he kernel contains all the neccessary things, but nope, hangs at TLP init / startup.
Couldn’t start lightdm …

I don’t remember if i tried the amd-… DRM driver from the AUR jet.
should i ?

Sorry for the wall of text and especially sorry if this is some easy bullshit that i was again, to dumb to find the simple search-keywords for.


#1409

Anyone know a quick and easy way to clear highlighting in vim? :wink:

For example:

/deployNewVersion()

Will keep that function highlighted. I usually do /! or /asdfs to clear the highlight. Is there a “real” way to do it?

After doing it today, I thought maybe I’m doing it wrong :frowning:


#1410

Yes, you can use the :nohl option in vim to clear any highlighting.


#1411

Nice, that’s super easy. THANK YOU

FYI (for any other with this weird, needy question :grin: ): :set hlsearch will turn it back on.

Weird, :nohl was hard impossible to find, people using these wacked out solutions. But set hlsearch was the first hit -_-


#1412

All right, now for the tough question… How do I exit vim? /s


#1413

I had a similar problem, it is one of those little known things that is very simple and catches out a lot of people.

With a great deal of difficulty, in all seriousness though you can exit vim with :q or with :q! if you’ve made changes and want to exit anyway, :wq to save changes and exit or :qa for :quitall or simply just :exit.


#1414

Greetings everyone, new to the site and forums and hoping to learn some new stuff and game on my Linux machine…

First things first, my PC specs

Gigabyte z97x-sli
i-5 4690k 3.5ghz
16gb DDR3 Corsair
Gtac 1060 Dual fan 6gb card
500gb SSD (windows), 4tb WD and 500gb WD (Ubuntu 18.04)

I am having a bit of an issue with getting Nvidia drivers to load, did a fresh install, updated system with latest updates. After reboot I logged in and did

sudo apt install nvidia-390

Reboot once again and got a black screen.

I haven’t tried doing -396 drivers as I ran out of time but wanted to check here and see if anyone knew of a solution or fix? I did notice a new kernal (4.15.0.29) and 4.15.0.20. I can load up fine into .20 and it’ll load the nouveau driber but .29 gives black screen. If I remove “no splash” from grub I also get

[FAIL] failed to start Load Kernal Module

Thanks

Knewt


#1415

This seems like the kernel module did not build successfully. Try reinstalling the driver and making sure the kernel module is built successfully.

I think the kernel module package is nvidia-dkms-version#, so you could try sudo dpkg -i nvidia-dkms-390 to directly reinstall the package rather then reinstalling the whole meta-package(ie nvidia-390)

Check to see if it builds successfully. If not, there may be dependences it did not pull in or something.


#1416

I’ll try then when I get back home tonight,

Appreciate your input


#1417

Na a clean install probablly won´t fix your issue with the Brisk menu.
The Brisk menu is really buggy in general it crashes allot.
I personally use the Mint menu which is allot more stable and just works better.
Allthough the best application menu in Linux is still the Whisker menu imo.
I really wished that the Whisker menu was forked into other DE´s.

But yeah the main complain i have about Ubuntu 18.04 in general,
is that the kernel 4.15.0.24 and also the 4.15.0.26 seem to have some major bug in it,
that doesnt seem to have been catched during testing.
They did pull the said .24 kernel, but still, novice users that dont know how to manage kernels on Ubuntu,
will have a really hard time to fix it, since Ubuntu by default doesnt offer any support on that like Linux Mint does.


#1418

Anyone remember what package gives me the .desktop shortcut editor called “Main Menu”


#1419

You need a package for that? I just right click -> Edit Menus on the taskbar menu (using MATE).


#1420

Gnome. Not included when adding gnome-session to ubuntu.