Return to

The small linux problem thread



Try changing DPI settings In Appearance (from Control Center) -> Fonts tab -> Details button.

Those instructions are for MATE. I’m not sure of the menus/settings in LXDE but you can look for something similar.



I did find a setting in obs that allows Monitoring of audio input… but after about 7 minutes of recording, the audio became muffled/terrible watching the playback.


Yeah I think I’ve done that before to work around it but I’m pretty sure that shouldn’t happen because it doesn’t happen with Xubuntu, at least not recently.


As far as I know LXDE doesn’t scale well on HDPI displays without manual config. You can try the following:

In your home directory, create a new text file named .Xresources
In this file, enter your desired DPI in the following format: Xft.dpi: 500
Restart the X server.

Some things still doesn’t scale with that setting, for ex. the the height of the taskbar - can set it manually via right click.


Nice, I will try that out and if it works, I’ll make a video about it on my channel. That’s a good tip.


ERROR: file:How to Download YouTube Videos or Playlists in Windows, Mac or Linux - Using youtube-dl-Zw4yNGoyR8E.temp.m4a: Invalid argument

It downloads fine but when it tries to extract the audio that’s when the problem occurs. Also I don’t get why right SHIFT key for copying and pasting into terminal doesn’t work. Only the left SHIFT key works.


Hold on, did I miss Nvidia open sourcing their drivers?


Could there be some missing dependency or something?
I don’t know how YT-DL works, presumably not just “Magic”


What is the best way to set appropriate user permissions to a volume?

An LVM “data” volume created during OS installation by anaconda/blivet-gui is owned by root and my user does not have write permissions. Is this normal? This volume is intended to be used as an OS-independent “home partition”.


Would you chown the mount point? (Recursively if there is anything inside)
So like

sudo chown -r username /mountpoint


chown could be one solution. Another might be the user/users mounting option in fstab?

I’m not sure of the ramifications of each and don’t want to get into trouble with permissions.


If it’s already made, I’d give it a punt.
What’s the worst that could happen?

I would test it first before mounting over /home/user though…


I don’t mean mounting over /home/user.

fstab mounting options:

user / users / nouser
user permits any user to mount the filesystem. This automatically implies noexec, nosuid, nodev unless overridden. If nouser is specified, only root can mount the filesystem. If users is specified, every user in group users will be able to unmount the volume.

‘defaults’ includes ‘nouser’

Use default settings. Default settings are defined per file system at the file system level. For ext3 file systems these can be set with the tune2fs command. The normal default for Ext3 file systems is equivalent to rw,suid,dev,exec,auto,nouser,async(no acl support). Modern Red Hat based systems set acl support as default on the root file system but not on user created Ext3 file systems. Some file systems such as XFS enable acls by default. Default file system mount attributes can be overridden in /etc/fstab.


Okay, My bad. I must read your post.

I followed @sgtawesomesauce guide and literally have a ZFS dataset mounted as my home folder, with additional datasets mounted as sub directories too.

His blog is pretty awesome:


No problem. chmod or chown might still be the way to go.

Just looking for some feedback on the best way to deal with permissions and volumes.


Aww, thanks hon. You’re making me blush.


Hey L1er’s. I’m trying to install the ./ file. I’m in run level 2 (command line) . I’m using RHEL 7.5. I was able to get the .iso mounted via the filesystem table but I’m not having luck running it as ./ (yes, I’m root).

I think I need to yum install gcc, make, perl and then install the kernel header files for the current kernel ( kernel-devel-3.10.0.-862.2.3.e17.x86_64.

Found a couple of articles on how to do this but wanted to run it by you guys first.


It’s possible. I don’t remember the process off the top of my head. I’d snapshot the VM before you start on it, that way you can restore if you get stuck.

I seem to remember needing compilation tools, but it’s also worth noting that RHEL might have the vbox additions in their package repos. In the Fedora repos, it’s called virtualbox-guest-additions. Might be worth running a yum search before you go compiling from source.


Nevermind, Yum is completely disabled on this specific distro I’m using. I’m going to have to use rpm.


Ah, Don’t you have a license? (you can get a developer license from their website)